Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056261 - Gear home dirs sometimes owned by user instead of root
Summary: Gear home dirs sometimes owned by user instead of root
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Dan McPherson
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 19:25 UTC by Stefanie Forrester
Modified: 2015-05-14 23:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-26 19:09:50 UTC


Attachments (Terms of Use)

Description Stefanie Forrester 2014-01-21 19:25:14 UTC
Description of problem:
Sometimes a user's home dir is created with incorrect permissions. Generally the directories in /var/lib/openshift are owned by root, but occasionally we're seeing some owned by the user instead. This only affects a few gears per node, but the issue is present on more than half of the nodes.

Example:
$ ls -ld /var/lib/openshift/52d980205973ca51ee0000d2
drwxr-x---. 16 52d980205973ca51ee0000d2 52d980205973ca51ee0000d2 4096 Jan 21 03:59 /var/lib/openshift/52d980205973ca51ee0000d2

Version-Release number of selected component (if applicable):
2.0.37

How reproducible:
Reproducible in environments with a large number of gears, since only a small percentage of them are affected. 

Steps to Reproduce:
1. Create a lot of gears.
2. Check to see if the issue has occurred. 
   find /var/lib/openshift -maxdepth 1 \! -user root
3.

Actual results:
Eventually 'find' will return with some gear dirs that have incorrect permissions.

Expected results:
All dirs in /var/lib/openshift should be owned by root.

Additional info:

Comment 1 Jhon Honce 2014-01-21 20:09:16 UTC
oo-accept-node has been enhanced to report this issue as of Sprint 2.0.39.

The symptom occurs when mcollective kills off the thread running the operation that locks/unlocks to the gear.

Comment 2 Dan McPherson 2014-02-08 00:58:32 UTC
Fixed in sprint 39.  The issue was every cart remove call was unlocking the gear home dir.

Comment 3 Meng Bo 2014-02-08 03:22:41 UTC
Checked on devenv_4346, with about 600 gears created on the node, it will not return the gear dir with user owned.

[root@ip-10-158-72-46 ~]# find /var/lib/openshift -maxdepth 1 \! -user root
[root@ip-10-158-72-46 ~]#


Note You need to log in before you can comment on or make changes to this bug.