Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056212 - ibus-typing-booster install dictionary and install pyhunspell PackageKit integration
Summary: ibus-typing-booster install dictionary and install pyhunspell PackageKit inte...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ibus-typing-booster
Version: 7.0
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: 7.0
Assignee: Mike FABIAN
QA Contact: QE Internationalization Bugs
URL:
Whiteboard:
Depends On: 1064923
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 17:11 UTC by Martin
Modified: 2016-05-24 07:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-19 05:36:17 UTC


Attachments (Terms of Use)
screenshot (deleted)
2014-01-21 17:43 UTC, Martin
no flags Details

Description Martin 2014-01-21 17:11:53 UTC
Version-Release number of selected component (if applicable):
RHEL-7.0-20140109.n.0

Steps to Reproduce: 
 1. Launch Region and Language (Settings -> Region and Language)
 2. In "Input Sources" click on the "+".
 3. Search for: "czech" .
 4. Select "Czech (Czech - CZ (Hunspell))" and click "Add" .
 5. Ensure Czech Hunspell is not installed: yum remove hunspell-cs -y

 
 1. Select input source "Czech (Czech - CZ (Hunspell))" and click on "gear" to
    open preferences.
 2. Select "Dictionaries and personal data"  tab.
 3. Click on "Install dictionary".

 
Actual results: 
PackageKit window pop-up with following description: "python requires additional software". There should be some meaningful description e.g.: "ibus-typing-booster requires additional software" or something like that.

Expected results:
  * Dialog providing installation of Czech dictionary should pop-up.
  * You can install Czech dictionary using PackageKit.
  * You should get Czech word suggestions during typing.

Comment 1 Martin 2014-01-21 17:43:22 UTC
Created attachment 853403 [details]
screenshot

Comment 2 Jens Petersen 2014-02-04 07:28:35 UTC
I suggest that requiring pyhunspell by default is a good idea.

Comment 3 Mike FABIAN 2014-02-10 15:25:47 UTC
(In reply to Martin Holec from comment #0)
> Actual results: 
> PackageKit window pop-up with following description: "python requires
> additional software". There should be some meaningful description e.g.:
> "ibus-typing-booster requires additional software" or something like that.

Apart from that it says “python requires ...” instead of
“ibus-typing-booster requires ...” the dialog is quite understandable,
I think. The package name hunspell-cz is also shown clearly in the dialog.

This is the code ibus-typing-booster uses to install a package:

https://git.fedorahosted.org/cgit/ibus-typing-booster.git/tree/ibus-typing-booster/setup/pkginstall.py

I have no idea how I can influence the text shown by this dialog.

> Expected results:
>   * Dialog providing installation of Czech dictionary should pop-up.

It does, doesn’t it?

>   * You can install Czech dictionary using PackageKit.

And that works.

>   * You should get Czech word suggestions during typing.

Works for me as well. I can install the Czech dictionary that
way and see Czech suggestions after doing that.

The setup tool for ibus-typing-booster has 2 buttons to install
stuff, one for the dictionary and one for pyhunspell, the interface
to the spell checker.

Both the dictionary and the spell checker interface are optional.

ibus-typing-booster also learns from user input and this actually
produces much better suggestions than the dictionary because it uses
the last 2 words as context (in applications supporting surrounding
text like most gnome-applications except gnome-terminal it gets the
last 2 words by fetching the surrounding text from the application, in
applications not supporting surrounding text it uses the last two
words remembered from typing). If the user has typed these last two
words before, he will get a much better suggestion than by just using
a dictionary.

If there are very many suggestions, it is not so useful for speeding
up typing. If no context is available and only a dictionary, one will
get so many suggestions after typing a single letter that it is almost
useless.  Selecting amoung dozends or even hundreds of suggestions is
often slower than just finishing to type the word. If context is
available and user input for the previous 2 words can be found in the
user database because the user has typed it before or has used the
feature to let ibus-typing-booster learn from a user supplied text
file, then the predictions are far better. The desired word is very
often the first match on top of the candidate list in that case.

So using the feature in the setup tool to let ibus-typing-booster
learn from a user supplied text file is much more helpful than the dictionary.

Using the dictionary is basically only a last ditch fallback if no
user input is available.

If only the dictionary is installed but not pyhunspell, one will get
only exact suggestions from the dictionary.

If pyhunspell is installed as well, one will also get spell checking
corrections if the word entered so far has typing errors.

Requiring hunspell-cs from the rpm is not possible because the rpm is the same for all languages and it should not require all hunspell-*.

(In future I plan to reduce the number of engines a lot and make it
more multilingual, i.e. support many languages with a single engine
so it is not a good idea to split the package into many subpackes for
each language now).

To summarize, both pyhunspell and hunspell-cs are really optional and only
marginally useful compared to good user data.

I’ll add “pyhunspell” to the rpm requires now because that is the same
for all languages and does not force a split of the package and it
saves at least one (optional) installation step for the user.
“pyhunspell” is very small so it should not hurt much to require it.

Comment 4 Mike FABIAN 2014-02-12 08:58:21 UTC
(In reply to Mike FABIAN from comment #3)

> To summarize, both pyhunspell and hunspell-cs are really optional and only
> marginally useful compared to good user data.
> 
> I’ll add “pyhunspell” to the rpm requires now because that is the same
> for all languages and does not force a split of the package and it
> saves at least one (optional) installation step for the user.
> “pyhunspell” is very small so it should not hurt much to require it.

I cannot  add “pyhunspell” to “Requires:” in ibus-typing-booster.spec for
rhel7 because “pyhunspell” does not even exist in rhel7:

https://brewweb.devel.redhat.com/packageinfo?packageID=38235

Comment 5 Mike FABIAN 2014-02-12 08:59:46 UTC
Closing as WONTFIX then because I cannot require pyhunspell.

Comment 6 Martin 2014-02-13 11:14:03 UTC
Please stick to bug description and ignore general expected results imported from Test Case.

Actual results: 
PackageKit window pop-up with following description: "python requires additional software". There should be some meaningful description e.g.: "ibus-typing-booster requires additional software" or something like that.

Comment 7 Martin 2014-02-13 11:20:51 UTC
(In reply to Mike FABIAN from comment #3)
> (In reply to Martin Holec from comment #0)
> > Actual results: 
> > PackageKit window pop-up with following description: "python requires
> > additional software". There should be some meaningful description e.g.:
> > "ibus-typing-booster requires additional software" or something like that.
> 
> Apart from that it says “python requires ...” instead of
> “ibus-typing-booster requires ...” the dialog is quite understandable,
> I think. The package name hunspell-cz is also shown clearly in the dialog.
> 
> This is the code ibus-typing-booster uses to install a package:
> 
> https://git.fedorahosted.org/cgit/ibus-typing-booster.git/tree/ibus-typing-
> booster/setup/pkginstall.py
> 
> I have no idea how I can influence the text shown by this dialog.

Just ask right guy...

Comment 8 Mike FABIAN 2014-02-13 14:54:02 UTC
Discussed it with Richard.

This is not so easy. See: https://bugzilla.redhat.com/show_bug.cgi?id=1064923

Comment 9 Jens Petersen 2014-02-17 09:49:42 UTC
Can yum or dnf be used instead of packagekit?

Comment 10 Jens Petersen 2014-02-17 09:56:21 UTC
I thought "ibus-typing-booster install dictionary integration" is bug 1056197 ?

Comment 11 Mike FABIAN 2014-02-17 10:11:02 UTC
(In reply to Jens Petersen from comment #9)
> Can yum or dnf be used instead of packagekit?

That would make it more distribution specific, wouldn’t it?

Comment 12 Ludek Smid 2014-06-26 10:51:54 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Comment 13 Ludek Smid 2014-06-26 11:14:21 UTC
The comment above is incorrect. The correct version is bellow.
I'm sorry for any inconvenience.
---------------------------------------------------------------

This request was NOT resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you need
to escalate this bug.

Comment 16 Mike FABIAN 2016-05-19 05:36:17 UTC
Closing as WONTFIX, there is no easy way to fix this and pyhunspell is optional anyway.


Note You need to log in before you can comment on or make changes to this bug.