Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056195 - KIE-CI attempts to download a KieModule, which is being built, from a Maven repo
Summary: KIE-CI attempts to download a KieModule, which is being built, from a Maven repo
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: BRE
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER1
: 6.0.1
Assignee: Mario Fusco
QA Contact: Marek Winkler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 16:39 UTC by Marek Winkler
Modified: 2014-08-06 19:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 19:58:55 UTC
Type: Bug


Attachments (Terms of Use)
Maven project with reproducer (deleted)
2014-01-21 16:39 UTC, Marek Winkler
no flags Details

Description Marek Winkler 2014-01-21 16:39:56 UTC
Created attachment 853360 [details]
Maven project with reproducer

Description of problem:

KIE-CI attempts to download a KieModule from a Maven repo while this KieModule is being built using KieBuilder.buildAll(). This results in long delays (several seconds) when building a KieModule when KIE-CI is on the classpath.

Please see the attached maven project with reproducer for details.

Although this behaviour seems to be present in ER7 as well, change of wagon provider to http-wagon has probably increased the delay.

Version-Release number of selected component (if applicable):

BRMS 6.0.0.CR1

Steps to Reproduce:

Unzip attached maven project and run mvn clean install. Comment kie-ci dependency in pom.xml for comparison.

Actual results:

Building 10 KieModules (and executing a trivial rule) takes about 60 seconds.

In ER7, the same test takes about 38 seconds.

Expected results:

Building 10 KieModules (and executing a trivial rule) takes similar time to the situation when kie-ci dependency is removed from the reproducer project - roughly 1.5 seconds.

Comment 1 Mario Fusco 2014-01-21 18:50:42 UTC
Fixed by https://github.com/droolsjbpm/drools/commit/ff4f9415a

Comment 2 Marek Winkler 2014-02-21 17:11:43 UTC
Verified on BRMS 6.0.1 ER1.


Note You need to log in before you can comment on or make changes to this bug.