Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056183 - Excluding provides causes failures in collections
Summary: Excluding provides causes failures in collections
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: scl-utils
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Zeleny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 16:19 UTC by Adam Miller
Modified: 2014-03-01 14:13 UTC (History)
3 users (show)

Fixed In Version: scl-utils-20140127-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-01 14:05:43 UTC


Attachments (Terms of Use)

Description Adam Miller 2014-01-21 16:19:59 UTC
Attempting to build a SCL for Fedora 20 for ruby193+rails4 I've run into the issue where the ruby193-ruby-libs package doesn't provide libruby.so.1.9()(64bit) which causes failures:

$ rpm -qp --provides /var/lib/mock/ruby193-fedora-20-x86_64/result/ruby193-ruby-libs-1.9.3.484-44.fc20.x86_64.rpm 
ruby193-ruby(abi) = 1.9.1
ruby193-ruby-libs = 1.9.3.484-44.fc20
ruby193-ruby-libs(x86-64) = 1.9.3.484-44.fc20
scl-package(ruby193) 


DEBUG util.py:264:  Getting requirements for ruby193-rubygem-bacon-1.1.0-8.fc20.src
DEBUG util.py:264:   --> ruby193-rubygems-devel-1.8.23-44.fc20.noarch
DEBUG util.py:264:  Error: Package: ruby193-ruby-libs-1.9.3.484-44.fc20.x86_64 (local_build_repo)
DEBUG util.py:264:             Requires: libruby.so.1.9()(64bit)
DEBUG util.py:264:  Error: Package: ruby193-rubygem-bigdecimal-1.1.0-44.fc20.x86_64 (local_build_repo)
DEBUG util.py:264:             Requires: libruby.so.1.9()(64bit)
DEBUG util.py:264:  Error: Package: ruby193-rubygem-io-console-0.3-44.fc20.x86_64 (local_build_repo)
DEBUG util.py:264:             Requires: libruby.so.1.9()(64bit)
DEBUG util.py:264:  Error: Package: ruby193-ruby-1.9.3.484-44.fc20.x86_64 (local_build_repo)
DEBUG util.py:264:             Requires: libruby.so.1.9()(64bit)
DEBUG util.py:264:   You could try using --skip-broken to work around the problem
DEBUG util.py:264:   You could try running: rpm -Va --nofiles --nodigest


I spoke with Vit(CC'd) on irc and he found this commit in the scl-utils git repo that appears to be causing the issue.

https://git.fedorahosted.org/cgit/scl-utils.git/commit/?id=7c41749b629865b125acfd28387883b0a80961a5

$ git show 7c41749b629865b
commit 7c41749b629865b125acfd28387883b0a80961a5
Author: Jan Zeleny <jzeleny@redhat.com>
Date:   Fri Sep 27 12:56:12 2013 +0200

    Don't generate provides from sonames in the SCL root

diff --git a/macros.scl b/macros.scl
index 1cc00ae..f961482 100644
--- a/macros.scl
+++ b/macros.scl
@@ -69,6 +69,7 @@ package or when debugging this package.
 %{nil}}
 BuildRequires: scl-utils-build
 Provides: scl-package(%scl)
+%global __provides_exclude_from ^(%{_libdir}/*.so.*)$
 }
 %{?scl_package_override:%scl_package_override}
 }

When building with an older version of scl-utils/scl-utils-build the package builds properly:

$ rpm -qp --provides /var/lib/mock/ruby193-fedora-20-x86_64/result/ruby193-ruby-libs-1.9.3.484-44.fc20.x86_64.rpm 
libruby.so.1.9()(64bit)  
ruby193-ruby(abi) = 1.9.1
ruby193-ruby-libs = 1.9.3.484-44.fc20
ruby193-ruby-libs(x86-64) = 1.9.3.484-44.fc20
scl-package(ruby193)

Comment 1 Fedora Update System 2014-01-27 12:07:58 UTC
scl-utils-20140127-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/scl-utils-20140127-1.fc19

Comment 2 Fedora Update System 2014-01-27 12:08:29 UTC
scl-utils-20140127-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/scl-utils-20140127-1.fc20

Comment 3 Fedora Update System 2014-01-28 04:37:00 UTC
Package scl-utils-20140127-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing scl-utils-20140127-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1623/scl-utils-20140127-1.fc19
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-03-01 14:05:43 UTC
scl-utils-20140127-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2014-03-01 14:13:44 UTC
scl-utils-20140127-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.