Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056155 - VDSM < 3.4 reporting QoS in 3.4 cluster produces ClassCastException
Summary: VDSM < 3.4 reporting QoS in 3.4 cluster produces ClassCastException
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.4.0
Assignee: Lior Vernia
QA Contact: Martin Pavlik
URL:
Whiteboard: network
: 1057275 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 15:28 UTC by Lior Vernia
Modified: 2015-05-05 01:44 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:29:03 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23752 None None None Never

Description Lior Vernia 2014-01-21 15:28:52 UTC
Description of problem:

When using a VDSM version < 3.4 on a host which is part of a 3.4 cluster, there is an issue with the deserialization of QoS reported by the host; even though the host should generally be non-operational in this setting, the deserialization takes place as part of the GetVdsCapabilities action, which should work without throwing exceptions even if the host is non-operational.


Version-Release number of selected component (if applicable):


How reproducible:

Always.


Steps to Reproduce:
1. Add a host with VDSM version corresponding to < 3.4 to a 3.4 cluster.

Actual results:

ClassCastException in engine log, even if no QoS is set on the host.


Expected results:

No exceptions.

Comment 1 Martin Pavlik 2014-02-12 12:40:34 UTC
verified
oVirt Engine Version: 3.4.0-0.7.beta2.el6 

host with vdsm < 3.4 in 3.4 cluster gets non-operational with following meesage 

Host dell-07 is compatible with versions (3.0,3.1,3.2,3.3) and cannot join Cluster Default which is set to version 3.4.

Comment 2 Moti Asayag 2014-02-23 15:42:42 UTC
*** Bug 1057275 has been marked as a duplicate of this bug. ***

Comment 3 Sandro Bonazzola 2014-03-31 12:29:03 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.