Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056154 - firewall-config creates unloadable config; port forwarding broken
Summary: firewall-config creates unloadable config; port forwarding broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 20
Hardware: i686
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1053878 1055076 (view as bug list)
Depends On:
Blocks: 1057628
TreeView+ depends on / blocked
 
Reported: 2014-01-21 15:25 UTC by todd_lewis
Modified: 2014-02-11 23:03 UTC (History)
5 users (show)

Fixed In Version: firewalld-0.3.9.3-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1057628 (view as bug list)
Environment:
Last Closed: 2014-02-11 23:03:05 UTC


Attachments (Terms of Use)
/etc/firewalld tree from firewall-config, unloadable by firewalld-cmd (deleted)
2014-01-21 15:25 UTC, todd_lewis
no flags Details

Description todd_lewis 2014-01-21 15:25:47 UTC
Created attachment 853318 [details]
/etc/firewalld tree from firewall-config, unloadable by firewalld-cmd

Description of problem: After setting basic port forwarding, firewalld-cmd dies with a python exception.


Version-Release number of selected component (if applicable):
firewall-config-0.3.9.2-1.fc20.noarch
firewalld-0.3.9.2-1.fc20.noarch


How reproducible: always


Steps to Reproduce:
1. yum erase firewalld ; rm -rf /etc/firewalld
2. yum install firewalld ; systemctl start firewalld
3. run firewall-config to set port forwarding
3. (fail to) run firewall-cmd --complete-reload

Actual results:
(in red:) Error: %x format: a number is required, not NoneType

Expected results:
Firewall loaded with port forwarding

Additional info:
attachment contains a tarball of the unloadable /etc/firewalld tree.

Comment 1 Jiri Popelka 2014-01-22 11:53:20 UTC
Backtrace:

  File "/home/jpopelka/git/firewalld/src/firewall/server/decorators.py", line 53, in dbus_handle_exceptions
    return func(*args, **kwargs)
  File "/home/jpopelka/git/firewalld/src/firewall/server/firewalld.py", line 771, in addInterface
    _zone = self.fw.zone.add_interface(zone, interface, sender)
  File "/home/jpopelka/git/firewalld/src/firewall/core/fw_zone.py", line 471, in add_interface
    self.apply_zone_settings(zone)
  File "/home/jpopelka/git/firewalld/src/firewall/core/fw_zone.py", line 360, in apply_zone_settings
    self.__zone_settings(True, zone)
  File "/home/jpopelka/git/firewalld/src/firewall/core/fw_zone.py", line 337, in __zone_settings
    self.__forward_port(enable, zone, *args)
  File "/home/jpopelka/git/firewalld/src/firewall/core/fw_zone.py", line 1325, in __forward_port
    mark_str = "0x%x" % mark_id
TypeError: %x format: a number is required, not NoneType

Comment 3 Jiri Popelka 2014-01-24 09:11:28 UTC
*** Bug 1055076 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2014-02-05 17:10:30 UTC
firewalld-0.3.9.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/firewalld-0.3.9.3-1.fc20

Comment 5 Fedora Update System 2014-02-07 03:05:10 UTC
Package firewalld-0.3.9.3-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firewalld-0.3.9.3-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2100/firewalld-0.3.9.3-1.fc20
then log in and leave karma (feedback).

Comment 6 Nils Philippsen 2014-02-07 16:59:57 UTC
*** Bug 1053878 has been marked as a duplicate of this bug. ***

Comment 7 Darrell Ford 2014-02-08 18:37:41 UTC
Confirmed initial bug exactly as reported and confirmed fix listed in Comment 5.

Comment 8 Fedora Update System 2014-02-11 23:03:05 UTC
firewalld-0.3.9.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.