Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056139 - TypeError: Argument 1 does not allow None as a value
Summary: TypeError: Argument 1 does not allow None as a value
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: mulhern
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:1c7c0b84fb2f5648ce6505513ee...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 14:54 UTC by Vratislav Podzimek
Modified: 2014-06-18 01:52 UTC (History)
4 users (show)

Fixed In Version: anaconda-19.31.51-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 09:27:42 UTC


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2014-01-21 14:54 UTC, Vratislav Podzimek
no flags Details
File: anaconda.log (deleted)
2014-01-21 14:54 UTC, Vratislav Podzimek
no flags Details
File: environ (deleted)
2014-01-21 14:54 UTC, Vratislav Podzimek
no flags Details
File: lsblk_output (deleted)
2014-01-21 14:54 UTC, Vratislav Podzimek
no flags Details
File: nmcli_dev_list (deleted)
2014-01-21 14:54 UTC, Vratislav Podzimek
no flags Details
File: os_info (deleted)
2014-01-21 14:54 UTC, Vratislav Podzimek
no flags Details
File: program.log (deleted)
2014-01-21 14:54 UTC, Vratislav Podzimek
no flags Details
File: storage.log (deleted)
2014-01-21 14:54 UTC, Vratislav Podzimek
no flags Details
File: syslog (deleted)
2014-01-21 14:55 UTC, Vratislav Podzimek
no flags Details
File: ifcfg.log (deleted)
2014-01-21 14:55 UTC, Vratislav Podzimek
no flags Details
File: packaging.log (deleted)
2014-01-21 14:55 UTC, Vratislav Podzimek
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1038590 None None None Never

Internal Links: 1038590

Description Vratislav Podzimek 2014-01-21 14:54:31 UTC
Description of problem:
Just entered the Custom spoke with updates.img from rhel7-branch

Version-Release number of selected component:
anaconda-19.31.42-1

The following was filed automatically by anaconda:
anaconda 19.31.42-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
  File "/tmp/updates/pyanaconda/ui/gui/spokes/custom.py", line 1737, in _populate_right_side
    self._labelEntry.set_text(getattr(device.format, "label", ""))
  File "/tmp/updates/pyanaconda/ui/gui/spokes/custom.py", line 2526, in on_selector_clicked
    self._populate_right_side(selector)
  File "/tmp/updates/pyanaconda/ui/gui/spokes/custom.py", line 2192, in _show_mountpoint
    self.on_selector_clicked(page.members[0])
  File "/tmp/updates/pyanaconda/ui/gui/spokes/custom.py", line 2545, in on_page_clicked
    self._show_mountpoint(page=page, mountpoint=mountpointToShow)
  File "/tmp/updates/pyanaconda/ui/gui/spokes/lib/accordion.py", line 146, in _onExpanded
    cb(obj.get_child())
TypeError: Argument 1 does not allow None as a value

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/test/vpodzime/rhel7/initrd.img,/test/vpodzime/initrd_overlay.img repo=http://download.englab.brq.redhat.com/nightly/RHEL-7.0-20140108.n.0/compose/Workstation/x86_64/os/ root=live:http://cobra02/trees/vp/rhel7_squashfs.img nokill updates=http://cobra02/ks/vp/rhel7_updates.img inst.dd BOOT_IMAGE=/test/vpodzime/rhel7/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.10.0-66.el7.x86_64
product:        Red Hat Enterprise Linux
release:        Red Hat Enterprise Linux Workstation release 7.0 Beta (Maipo)
type:           anaconda
version:        7.0

Comment 1 Vratislav Podzimek 2014-01-21 14:54:38 UTC
Created attachment 853292 [details]
File: anaconda-tb

Comment 2 Vratislav Podzimek 2014-01-21 14:54:40 UTC
Created attachment 853293 [details]
File: anaconda.log

Comment 3 Vratislav Podzimek 2014-01-21 14:54:44 UTC
Created attachment 853294 [details]
File: environ

Comment 4 Vratislav Podzimek 2014-01-21 14:54:46 UTC
Created attachment 853295 [details]
File: lsblk_output

Comment 5 Vratislav Podzimek 2014-01-21 14:54:50 UTC
Created attachment 853296 [details]
File: nmcli_dev_list

Comment 6 Vratislav Podzimek 2014-01-21 14:54:52 UTC
Created attachment 853297 [details]
File: os_info

Comment 7 Vratislav Podzimek 2014-01-21 14:54:55 UTC
Created attachment 853298 [details]
File: program.log

Comment 8 Vratislav Podzimek 2014-01-21 14:54:57 UTC
Created attachment 853299 [details]
File: storage.log

Comment 9 Vratislav Podzimek 2014-01-21 14:55:01 UTC
Created attachment 853300 [details]
File: syslog

Comment 10 Vratislav Podzimek 2014-01-21 14:55:05 UTC
Created attachment 853301 [details]
File: ifcfg.log

Comment 11 Vratislav Podzimek 2014-01-21 14:55:12 UTC
Created attachment 853302 [details]
File: packaging.log

Comment 13 mulhern 2014-01-21 17:13:40 UTC
This is actually a fix for a problem caused by a patch for #1038590.

Comment 14 mulhern 2014-01-22 15:11:42 UTC
Fixed in Version: anaconda-19.31.51

Comment 16 Jan Stodola 2014-03-25 12:02:58 UTC
Anne,
bug 1080409 has very similar traceback to this one, could you please check it? Are these bugs duplicates or not?

Comment 17 Vratislav Podzimek 2014-03-25 13:05:55 UTC
From the first glance these two look like different bugs.

Comment 18 mulhern 2014-03-26 11:49:56 UTC
I concur. It's a very similar problem, but since it's the device name, not the filesystem label that's showing up as None for bz#1080409 it's a different issue.

Comment 19 Jan Stodola 2014-04-09 10:09:02 UTC
Unable to reproduce the original issue since the compose is no longer available, but I verified that custom partitioning works properly when reusing, creating and modifying mount points with no label.
Tested with anaconda-19.31.75-1.el7.

Verified: SanityOnly

Comment 20 Ludek Smid 2014-06-13 09:27:42 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.