Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056122 - php-sabre-vobject "does not properly escape multiline property values"
Summary: php-sabre-vobject "does not properly escape multiline property values"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: php-sabre-vobject
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/bokxing-it/sabre-z...
Whiteboard:
Depends On: 1058694
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 14:32 UTC by Matěj Cepl
Modified: 2018-04-11 09:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-26 06:38:02 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2014-01-21 14:32:31 UTC
Description of problem:
I am not sure what does it mean, but it is the reason https://github.com/bokxing-it/sabre-zarafa/blob/master/README.md why sabre-zarafa requires php-sabre-vobject 3.*.

Filed a bug upstream to investigate a possibility of patching our package with fix for this issue (whatever it is).

Version-Release number of selected component (if applicable):
php-sabre-vobject-2.1.3-1.el6.noarch

Comment 1 Remi Collet 2014-01-21 15:13:13 UTC
thinking..

We have in the repo:

From the old deprecated and unmaintained pear channel, used by owncloud:

php-sabredav-Sabre_DAV 1.7.8
php-sabredav-Sabre_VObject 2.1.0

And from the github repo, maintained, used by horde (under review)

php-sabre-dav 1.8.7
php-sabre-vobject 2.1.3

Horde is already patched to ensure sabre class will be load for correct location.

A solution could be to update 
php-sabredav-Sabre_VObject => 2.1.3 (bugfix only)
php-sabre-vobject 3.1 (new version)

So zarafa will be able to use the wanted version.

Just need to improve the horde autoloader patch to take DAV from one location and VObject from another... a bit ugly...

Comment 2 Remi Collet 2014-02-20 12:00:41 UTC
php-sabre-vobject updated to 3.1.3 in rawhide (and soon in EPEL-7).

I think we are stick (for EPEL-6) because of owncloud 4 (see bug #1058694)

Comment 3 Fedora Update System 2014-03-03 12:04:32 UTC
php-sabre-vobject-3.1.3-1.fc20,php-horde-Horde-Autoloader-2.0.1-5.fc20,php-horde-Horde-Dav-1.0.3-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/php-sabre-vobject-3.1.3-1.fc20,php-horde-Horde-Autoloader-2.0.1-5.fc20,php-horde-Horde-Dav-1.0.3-3.fc20

Comment 4 Fedora Update System 2014-03-15 15:01:59 UTC
php-sabre-vobject-3.1.3-1.fc20, php-horde-Horde-Autoloader-2.1.0-1.fc20, php-horde-Horde-Dav-1.0.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Remi Collet 2016-04-26 06:38:02 UTC
version 3.x is in the repo.


Note You need to log in before you can comment on or make changes to this bug.