Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056051 - Add AArch64 support to qtdeclarative
Summary: Add AArch64 support to qtdeclarative
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtdeclarative
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1040452 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 13:29 UTC by Marcin Juszkiewicz
Modified: 2014-02-02 21:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-02 21:29:35 UTC


Attachments (Terms of Use)
full changeset (deleted)
2014-01-21 13:29 UTC, Marcin Juszkiewicz
no flags Details | Diff

Description Marcin Juszkiewicz 2014-01-21 13:29:51 UTC
Created attachment 853223 [details]
full changeset

Description of problem:

Qt5 uses code from double-conversion project. There was a bug reported there for AArch64 support: https://code.google.com/p/double-conversion/issues/detail?id=33 and it got merged but in a wrong way. I reopened their bug so they fixed issue for good now.

But Qt5 will merge that fix in 5.3 so we need to patch.

Version-Release number of selected component (if applicable):

5.2.0

How reproducible:

always

Steps to Reproduce:
1. build package on aarch64
2.
3.

Actual results:

fails

Expected results:

builds

Additional info:

Patch contains two patches backported from upstream - wrong fix and fix to fix.

Comment 1 Marcin Juszkiewicz 2014-01-24 16:48:47 UTC
Upstream Qt merged latest double-conversion code.

Comment 2 Rex Dieter 2014-02-02 21:25:14 UTC
*** Bug 1040452 has been marked as a duplicate of this bug. ***

Comment 3 Rex Dieter 2014-02-02 21:29:35 UTC
imported into rawhide, thanks.

%changelog
* Sun Feb 02 2014 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> 5.2.0-6
- Add AArch64 support (RHBUG: 1040452, QTBUG-35528)


Note You need to log in before you can comment on or make changes to this bug.