Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056009 - Weld regression, EAR/lib/foo.jar @Named bean no longer visible via EL in EAR/bar.war
Summary: Weld regression, EAR/lib/foo.jar @Named bean no longer visible via EL in EAR/...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CDI/Weld
Version: 6.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: DR0
: EAP 6.3.0
Assignee: Jozef Hartinger
QA Contact: Marek Schmidt
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks: 1057134
TreeView+ depends on / blocked
 
Reported: 2014-01-21 11:28 UTC by Marek Schmidt
Modified: 2014-06-28 15:30 UTC (History)
4 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1057134 (view as bug list)
Environment:
Last Closed: 2014-06-28 15:30:08 UTC
Type: Bug


Attachments (Terms of Use)
reproducer (deleted)
2014-01-21 11:28 UTC, Marek Schmidt
no flags Details


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker WELD-1589 Critical Resolved Regression, EAR/lib/foo.jar with @Named no longer visible in EAR/bar.war 2018-08-03 09:48:27 UTC

Description Marek Schmidt 2014-01-21 11:28:32 UTC
Created attachment 853167 [details]
reproducer

Description of problem:

EAR/lib/foo.jar and EAR/bar.war

foo.jar:

import javax.inject.Named;

@Named("echo")
public class CommonEcho {
    public String getText() {
        return "CommonEcho";
    }
}

and a page in bar.war:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"
    xmlns:h="http://java.sun.com/jsf/html"
    xmlns:ui="http://java.sun.com/jsf/facelets">
<h:head>
</h:head>
<h:body>
    <h:outputText value="#{echo.text}" />
</h:body>
</html>

no longer works in Weld 1.1.17.Final


Version-Release number of selected component (if applicable):
found on eap6.2.0.CP1.CR1 preview bits, weld-core-1.1.17.Final-redhat-1

How reproducible:
always

Steps to Reproduce:
1. deploy the attached EAR
2. go to http://127.0.0.1:8080/webapp-s2/index.jsf
3. page will be empty, while "CommonEcho" should be visible

Actual results:
page will be empty

Expected results:
"CommonEcho" should be visible

Additional info:

this issue seems to be related to the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1052277

Comment 2 JBoss JIRA Server 2014-01-29 14:58:00 UTC
Jozef Hartinger <jharting@redhat.com> updated the status of jira WELD-1589 to Resolved

Comment 3 Marek Schmidt 2014-02-21 09:08:53 UTC
verified on EAP 6.3.0.DR0


Note You need to log in before you can comment on or make changes to this bug.