Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055952 - [NetworkLabels] Missing 'Edit network' button on labeled networks which are attached to a nic in 'setup networks' dialog
Summary: [NetworkLabels] Missing 'Edit network' button on labeled networks which are a...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.4.0
Assignee: Lior Vernia
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks: 1055188
TreeView+ depends on / blocked
 
Reported: 2014-01-21 10:24 UTC by Moti Asayag
Modified: 2015-05-05 01:44 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:30:42 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23554 None None None Never

Description Moti Asayag 2014-01-21 10:24:20 UTC
Description of problem:
The button for editing the network's boot protocol doesn't appear for labeled networks which are attached to an interface by the label in the setup networks dialog.

The context menu presents an empty list of actions, therefore it isn't feasible as well to set boot protocol for those networks.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Label network 'red' with 'lbl'
2. Assign 'red' to cluster X
3. Open setup networks dialog for host in cluster X
4. Label a nic with 'lbl'
5. Once the network attached to the nic, notice no 'edit network' (pencil icon) appears and the context menu is also empty.

Actual results:
No button appears, nor context menu

Expected results:
Both button and context menu should appear for labeled networks

Additional info:

Comment 1 Martin Pavlik 2014-02-12 12:28:10 UTC
 oVirt Engine Version: 3.4.0-0.7.beta2.el6

Comment 2 Sandro Bonazzola 2014-03-31 12:30:42 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.