Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055897 - SELinux is preventing /usr/bin/systemd-tmpfiles from using the 'net_admin' capabilities.
Summary: SELinux is preventing /usr/bin/systemd-tmpfiles from using the 'net_admin' ca...
Keywords:
Status: CLOSED DUPLICATE of bug 1054337
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6c71b6ffe50b9cedb1ef3ac8c69...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 07:53 UTC by Christopher Meng
Modified: 2014-01-21 14:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-21 14:31:14 UTC


Attachments (Terms of Use)

Description Christopher Meng 2014-01-21 07:53:37 UTC
Description of problem:
SELinux is preventing /usr/bin/systemd-tmpfiles from using the 'net_admin' capabilities.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that systemd-tmpfiles should have the net_admin capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-tmpfile /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_tmpfiles_t:s0
Target Context                system_u:system_r:systemd_tmpfiles_t:s0
Target Objects                 [ capability ]
Source                        systemd-tmpfile
Source Path                   /usr/bin/systemd-tmpfiles
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           systemd-208-11.fc21.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-14.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.13.0-0.rc8.git4.2.fc21.i686 #1
                              SMP Sat Jan 18 16:29:05 UTC 2014 i686 i686
Alert Count                   1
First Seen                    2014-01-21 15:47:06 CST
Last Seen                     2014-01-21 15:47:06 CST
Local ID                      7045aedf-8277-4c38-b832-dbe05d054a40

Raw Audit Messages
type=AVC msg=audit(1390290426.218:405): avc:  denied  { net_admin } for  pid=2915 comm="systemd-tmpfile" capability=12  scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:system_r:systemd_tmpfiles_t:s0 tclass=capability


type=SYSCALL msg=audit(1390290426.218:405): arch=i386 syscall=socketcall success=no exit=EPERM a0=e a1=bf9202d0 a2=b7795df4 a3=3 items=0 ppid=1 pid=2915 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=systemd-tmpfile exe=/usr/bin/systemd-tmpfiles subj=system_u:system_r:systemd_tmpfiles_t:s0 key=(null)

Hash: systemd-tmpfile,systemd_tmpfiles_t,systemd_tmpfiles_t,capability,net_admin

Additional info:
reporter:       libreport-2.1.11
hashmarkername: setroubleshoot
kernel:         3.13.0-0.rc8.git4.2.fc21.i686
type:           libreport

Potential duplicate: bug 1054337

Comment 1 Miroslav Grepl 2014-01-21 14:31:14 UTC

*** This bug has been marked as a duplicate of bug 1054337 ***


Note You need to log in before you can comment on or make changes to this bug.