Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055862 - Error deploying cfn heat template with neutron multiple tenant network -Multiple possible networks found, use a Network ID to be more specific. (HTTP 400)
Summary: Error deploying cfn heat template with neutron multiple tenant network -Multi...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: RHOS Maint
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 05:14 UTC by Rabi Mishra
Modified: 2015-02-23 21:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 20:42:15 UTC


Attachments (Terms of Use)

Description Rabi Mishra 2014-01-21 05:14:44 UTC
Description of problem:

Deploying wordpress single instance template with multiple tenant networks results in error.

2014-01-20 20:34:32.884 1078 INFO heat.engine.resource [-] creating Instance "WikiDatabase"
2014-01-20 20:34:35.184 1078 ERROR heat.engine.resource [-] CREATE : Instance "WikiDatabase"
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource Traceback (most recent call last):
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource   File "/usr/lib/python2.6/site-packages/heat/engine/resource.py", line 362, in _do_action
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource     handle_data = handle()
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource   File "/usr/lib/python2.6/site-packages/heat/engine/resources/instance.py", line 354, in handle_create
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource     availability_zone=availability_zone)
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource   File "/usr/lib/python2.6/site-packages/novaclient/v1_1/servers.py", line 658, in create
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource     **boot_kwargs)
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource   File "/usr/lib/python2.6/site-packages/novaclient/base.py", line 402, in _boot
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource     return_raw=return_raw, **kwargs)
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource   File "/usr/lib/python2.6/site-packages/novaclient/base.py", line 145, in _create
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource     _resp, body = self.api.client.post(url, body=body)
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource   File "/usr/lib/python2.6/site-packages/novaclient/client.py", line 232, in post
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource     return self._cs_request(url, 'POST', **kwargs)
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource   File "/usr/lib/python2.6/site-packages/novaclient/client.py", line 213, in _cs_request
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource     **kwargs)
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource   File "/usr/lib/python2.6/site-packages/novaclient/client.py", line 195, in _time_request
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource     resp, body = self.request(url, method, **kwargs)
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource   File "/usr/lib/python2.6/site-packages/novaclient/client.py", line 189, in request
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource     raise exceptions.from_response(resp, body, url, method)
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource BadRequest: Multiple possible networks found, use a Network ID to be more specific. (HTTP 400) (Request-ID: req-5ba89873-866e-42e5-b5a8-aee1938bea9c)
2014-01-20 20:34:35.184 1078 TRACE heat.engine.resource 


Version-Release number of selected component (if applicable):

RHEL OSP 4.0

How reproducible:

Deploy multi-node RHEL OSP4. Deploy WordPress_Single_Instance.template. 

Steps to Reproduce:

1. Deploy multi-node RHEL OSP4
2. Create multiple tenant networks for demo tenant.
3.heat create teststack --template-file=WordPress_Single_Instance.template --parameters="InstanceType=m1.small;DBUsername=wp;DBPassword=wp;KeyName=heat_key;LinuxDistribution=F17"

Actual results:
BadRequest: Multiple possible networks found, use a Network ID to be more specific. (HTTP 400) (Request-ID: req-5ba89873-866e-42e5-b5a8-aee1938bea9c)

Expected results:

Should select one of the possible networks or both networks.

Additional info:

Comment 2 Steven Dake 2014-01-21 08:03:05 UTC
Steve Baker,

My thought is this is working as intended, since it is not reliable to randomly connect various networks to an instance.  Could you verify that logic is correct, or provide your thoughts on how this should work if it is indeed broken?

Comment 4 Zane Bitter 2014-07-23 20:42:15 UTC
This is not a bug as such, but it is a commonly-asked question:

https://ask.openstack.org/en/question/10085/multiple-possible-networks-found-use-a-network-id-to-be-more-specific/?answer=25956#post-id-25956


Note You need to log in before you can comment on or make changes to this bug.