Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055780 - [abrt] icedtea-web-1.4.1-1.fc20: Uncaught exception in method readRecord
Summary: [abrt] icedtea-web-1.4.1-1.fc20: Uncaught exception in method readRecord
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: icedtea-web
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ed0c7efa97918f0fddb6c1190cc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 22:05 UTC by Bob Doolittle
Modified: 2014-01-20 22:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-20 22:09:31 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2014-01-20 22:05 UTC, Bob Doolittle
no flags Details
File: environ (deleted)
2014-01-20 22:05 UTC, Bob Doolittle
no flags Details
File: jvm_environment (deleted)
2014-01-20 22:05 UTC, Bob Doolittle
no flags Details

Description Bob Doolittle 2014-01-20 22:05:37 UTC
Version-Release number of selected component:
icedtea-web-1.4.1-1.fc20

Additional info:
reporter:       libreport-2.1.11
cmdline:        java -agentpath:/usr/lib64/libabrt-java-connector.so=abrt=on -Xbootclasspath/a:/usr/share/icedtea-web/netx.jar:/usr/share/icedtea-web/plugin.jar:/usr/share/java/js.jar -classpath /usr/lib/jvm/jre-openjdk/lib/rt.jar sun.applet.PluginMain /var/tmp/icedteaplugin-rad/2944-icedteanp-plugin-to-appletviewer /var/tmp/icedteaplugin-rad/2944-icedteanp-appletviewer-to-plugin
executable:     /usr/share/icedtea-web/plugin.jar
java_executable: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.4.0.fc20.x86_64/jre-abrt/bin/java
kernel:         3.12.7-300.fc20.x86_64
pid:            2951
runlevel:       N 5
uid:            26770

Truncated backtrace:
Exception in thread "JHttpSocket GET" java.lang.ThreadDeath
	at java.lang.Thread.stop(Thread.java:835) [jar:file:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.4.0.fc20.x86_64/jre/lib/rt.jar!/java/lang/Thread.class]
	at iM.e(Unknown Source) [unknown]
	at bP.e(Unknown Source) [unknown]
	at bN.e(Unknown Source) [unknown]
	at bR.h(Unknown Source) [unknown]
	at bR.e(Unknown Source) [unknown]
	at bT.e(Unknown Source) [unknown]
	at bB.c(Unknown Source) [unknown]
	at bB.b(Unknown Source) [unknown]
	at bI.b_(Unknown Source) [unknown]
	at ko.b(Unknown Source) [unknown]
	at jd.run(Unknown Source) [unknown]

Comment 1 Bob Doolittle 2014-01-20 22:05:39 UTC
Created attachment 852871 [details]
File: backtrace

Comment 2 Bob Doolittle 2014-01-20 22:05:41 UTC
Created attachment 852872 [details]
File: environ

Comment 3 Bob Doolittle 2014-01-20 22:05:43 UTC
Created attachment 852873 [details]
File: jvm_environment

Comment 4 Deepak Bhole 2014-01-20 22:09:31 UTC
This is not a bug in icedtea-web as it is happening purely in obsfucated applet code.

Please contact the applet vendor about this.


Note You need to log in before you can comment on or make changes to this bug.