Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055749 - SELinux is preventing /usr/lib64/dbus-1/dbus-daemon-launch-helper from 'entrypoint' accesses on the file .
Summary: SELinux is preventing /usr/lib64/dbus-1/dbus-daemon-launch-helper from 'entry...
Keywords:
Status: CLOSED DUPLICATE of bug 1108247
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:46f920768651d100c1dbdc42780...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 20:55 UTC by Igor Gnatenko
Modified: 2014-06-11 15:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-11 15:29:17 UTC


Attachments (Terms of Use)

Description Igor Gnatenko 2014-01-20 20:55:00 UTC
Description of problem:
SELinux is preventing /usr/lib64/dbus-1/dbus-daemon-launch-helper from 'entrypoint' accesses on the file .

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that dbus-daemon-launch-helper should be allowed entrypoint access on the  file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dbus-daemon-lau /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0-s0:c0.c1023
Target Context                system_u:object_r:bin_t:s0
Target Objects                 [ file ]
Source                        dbus-daemon-lau
Source Path                   /usr/lib64/dbus-1/dbus-daemon-launch-helper
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dbus-1.6.18-2.fc21.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-13.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.13.0-0.rc8.git4.1.fc21.x86_64 #1
                              SMP Sat Jan 18 14:44:21 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-01-21 00:54:04 MSK
Last Seen                     2014-01-21 00:54:04 MSK
Local ID                      257a7889-dde7-4584-9cab-07bd67df7301

Raw Audit Messages
type=AVC msg=audit(1390251244.63:448): avc:  denied  { entrypoint } for  pid=3336 comm="dbus-daemon-lau" path="/usr/libexec/geoclue" dev="dm-1" ino=537668 scontext=system_u:system_r:initrc_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file


type=SYSCALL msg=audit(1390251244.63:448): arch=x86_64 syscall=execve success=no exit=EACCES a0=7f31a39de7e0 a1=7f31a39de680 a2=7f31a39dd010 a3=0 items=0 ppid=3335 pid=3336 auid=4294967295 uid=997 gid=996 euid=997 suid=997 fsuid=997 egid=996 sgid=996 fsgid=996 ses=4294967295 tty=(none) comm=dbus-daemon-lau exe=/usr/lib64/dbus-1/dbus-daemon-launch-helper subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: dbus-daemon-lau,initrc_t,bin_t,file,entrypoint

Additional info:
reporter:       libreport-2.1.11
hashmarkername: setroubleshoot
kernel:         3.13.0-0.rc8.git4.1.fc21.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-01-21 11:11:56 UTC
commit 5d7d8d41992a679e87c58c44ddff6a5d1e1de0e2
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Tue Jan 21 12:10:15 2014 +0100

    Add policy for Geoclue. Geoclue is a D-Bus service that provides location information.

Comment 2 Dan Mashal 2014-02-13 04:50:29 UTC
Got the same thing for a different process:

SELinux is preventing /usr/lib64/dbus-1/dbus-daemon-launch-helper from entrypoint access on the file .

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that dbus-daemon-launch-helper should be allowed entrypoint access on the  file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dbus-daemon-lau /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0-s0:c0.c1023
Target Context                system_u:object_r:bin_t:s0
Target Objects                 [ file ]
Source                        dbus-daemon-lau
Source Path                   /usr/lib64/dbus-1/dbus-daemon-launch-helper
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dbus-1.6.18-3.fc21.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-22.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux localhost.localdomain
                              3.14.0-0.rc2.git1.1.fc21.x86_64 #1 SMP Tue Feb 11
                              16:16:51 UTC 2014 x86_64 x86_64
Alert Count                   4
First Seen                    2014-02-12 15:40:16 PST
Last Seen                     2014-02-12 20:40:22 PST
Local ID                      3a62f902-4972-4136-877e-d79c85ea6b7b

Raw Audit Messages
type=AVC msg=audit(1392266422.746:383): avc:  denied  { entrypoint } for  pid=1599 comm="dbus-daemon-lau" path="/usr/libexec/msd-datetime-mechanism" dev="sda3" ino=263838 scontext=system_u:system_r:initrc_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file


type=SYSCALL msg=audit(1392266422.746:383): arch=x86_64 syscall=execve success=no exit=EACCES a0=7f2e92397720 a1=7f2e923976d0 a2=7f2e92396010 a3=0 items=0 ppid=1598 pid=1599 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=dbus-daemon-lau exe=/usr/lib64/dbus-1/dbus-daemon-launch-helper subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: dbus-daemon-lau,initrc_t,bin_t,file,entrypoint


This is from mate-settings-daemon and should be OK.

Comment 3 Miroslav Grepl 2014-02-13 11:13:57 UTC
Could you try to execute

# chcon -t gnomeclock_exec_t /usr/libexec/msd-datetime-mechanism

to see if it works?

Comment 4 Miroslav Grepl 2014-06-11 15:29:17 UTC

*** This bug has been marked as a duplicate of bug 1108247 ***


Note You need to log in before you can comment on or make changes to this bug.