Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055723 - saved sessions ignore programs launched from script.
Summary: saved sessions ignore programs launched from script.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xfdesktop
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 19:55 UTC by jamie
Modified: 2014-01-21 03:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-21 03:59:44 UTC


Attachments (Terms of Use)
The script I use to lauch thunderbird. (deleted)
2014-01-20 19:55 UTC, jamie
no flags Details

Description jamie 2014-01-20 19:55:17 UTC
Created attachment 852825 [details]
The script I use to lauch thunderbird.

Description of problem:
If I run a program form a batch script and save the session(by logging out), when I log in a again, the program is run but not the script. I've attached a script I wrote which I use to run thunderbird. The problem being in this case is that "LANG=en_US" is not set when the session is restored. 
Version-Release number of selected component (if applicable):
Don't know the version number. 

How reproducible:


Steps to Reproduce:
1.Write a script or use mine. 
2.Run the script
3.Log out and save the session 
4.Log in and the program will run but without the script. 
Actual results:
The program launched from the script will run without the rest of the script. 

Expected results:
The whole script should run. 
Additional info:
This is medium priority but it could be more urgent, it depends, I can't think of any cases where this is critical.

Comment 1 Kevin Fenzi 2014-01-21 03:34:51 UTC
There's no way for Xfce to know what commands you ran before some running process. When it saves a session it asks applications to 'save themselves' which usually involves any command line arguments and geometry if they support that. 

Anyhow, a possible work around for you: go to preferences->sessions and startup
and the application autostart tab. Click add. Enter the information for calling your script, save. 

The downside to this is that thunderbird could also be saved in your normal session.

Comment 2 jamie 2014-01-21 03:59:44 UTC
I guess this is not a bug then. I could write a script that kills any Thunderbirds(that sounds violent) and runs my script at start-up. This would work 99% of the time, since I normally want to start thunderbird when I login.


Note You need to log in before you can comment on or make changes to this bug.