Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055703 - Reopening Guided Rule with DSL will replace all DSLs
Summary: Reopening Guided Rule with DSL will replace all DSLs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: CR2
: 6.0.0
Assignee: manstis
QA Contact: Jiri Locker
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 18:55 UTC by Jiri Locker
Modified: 2014-08-06 20:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:17:29 UTC
Type: Bug


Attachments (Terms of Use)
CreditApproval with DSL before saving (deleted)
2014-01-20 18:56 UTC, Jiri Locker
no flags Details
CreditApproval reopened (deleted)
2014-01-20 18:56 UTC, Jiri Locker
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 993052 None None None Never
Red Hat Bugzilla 1069283 None None None Never

Internal Links: 993052 1069283

Description Jiri Locker 2014-01-20 18:55:20 UTC
Description of problem:
When the rule is saved and reopened, DSL sentences are replaced with equivalent guided editor elements. Validation fails on attempt to expand already expanded DRL source. I think the problem is caused by saving DRL source of .rdslr rules while the unexpanded DSL sentences should be saved.

Version-Release number of selected component (if applicable):
The first affected build is probably ER5.

How reproducible:
-

Steps to Reproduce:
1. open CreditApproval rule in mortgages
2. hit Save without making any changes
3. close and reopen the rule

Actual results:
All DSL sentences are gone, replaced with guided DRL equivalent.

Expected results:
After saving and reopening the rule, the editor should show the DSL sentences that were used as the rule was saved.

Additional info:

Comment 1 Jiri Locker 2014-01-20 18:56:05 UTC
Created attachment 852818 [details]
CreditApproval with DSL before saving

Comment 2 Jiri Locker 2014-01-20 18:56:52 UTC
Created attachment 852819 [details]
CreditApproval reopened

Comment 3 manstis 2014-01-21 11:12:22 UTC
This looks to be caused by the change to show "source" as the expanded DRL.

I'll verify and fix.

Comment 5 Edson Tirelli 2014-01-22 21:41:31 UTC
(6.0.0.GA.x): http://github.com/droolsjbpm/drools-wb/commit/73b44a1

Cheery-picked into 6.0.0.CR2.


Note You need to log in before you can comment on or make changes to this bug.