Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055656 - VDSM - hooks - after_update_device_fail hook fails
Summary: VDSM - hooks - after_update_device_fail hook fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.3.1
Assignee: Assaf Muller
QA Contact: sefi litmanovich
URL:
Whiteboard: network
Depends On: 1047646
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 17:27 UTC by rhev-integ
Modified: 2016-02-10 19:46 UTC (History)
12 users (show)

Fixed In Version: is34
Doc Type: Bug Fix
Doc Text:
after_update_device now runs as expected after a hook fails to run.
Clone Of: 1047646
Environment:
Last Closed: 2014-02-27 09:43:28 UTC
oVirt Team: Network


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0219 normal SHIPPED_LIVE vdsm 3.3.1 bug fix update 2014-02-27 14:42:16 UTC
oVirt gerrit 22922 None None None Never
oVirt gerrit 22950 None None None Never

Comment 2 Dan Kenigsberg 2014-02-02 17:12:45 UTC
http://gerrit.ovirt.org/#/c/22950/ is merged and would be included in the upcoming 3.3.1.

Comment 4 sefi litmanovich 2014-02-06 16:00:27 UTC
Verified on RHEL6.5 RHEVM3.3.1 is34.

Steps to Reproduce:

1. add some script to /usr/libexec/vdsm/hooks/after_update_device_fail/ that does something e.g "touch /var/tmp/somefile".
2. set permission for the script, CHMOD 755.
3. Invoke the hook. I did:
a) vdsClient -s rose07.qa.lab.tlv.redhat.com vmUpdateDevice 976cea23-3cc8-43bc-9b8f-b26269534af8 deviceType=interface alias=net0 network=giasfkasf

b) update fails.
4. /var/tmp/somefile found.

Comment 6 errata-xmlrpc 2014-02-27 09:43:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0219.html


Note You need to log in before you can comment on or make changes to this bug.