Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055655 - the xfs dump rpm does not include all of the required directories to allow the full functionality of the commands
Summary: the xfs dump rpm does not include all of the required directories to allow th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xfsdump
Version: 6.5
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Eric Sandeen
QA Contact: XuWang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 17:26 UTC by Paul Robert Marino
Modified: 2014-10-14 07:50 UTC (History)
1 user (show)

Fixed In Version: xfsdump-3.0.4-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:50:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1565 normal SHIPPED_LIVE xfsdump bug fix update 2014-10-14 01:27:43 UTC

Description Paul Robert Marino 2014-01-20 17:26:53 UTC
Description of problem:
The directory structure under /var/lib/xfsdump/ among other things this breaks the incremental backup feature of the xfsdump command and completely breaks the xfsinvutil command 

Version-Release number of selected component (if applicable):
"
# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.4 (Santiago)

# rpm -qi xfsdump
Name        : xfsdump                      Relocations: (not relocatable)
Version     : 3.0.4                             Vendor: Red Hat, Inc.
Release     : 3.el6                         Build Date: Tue 23 Oct 2012 01:50:25 PM EDT
Install Date: Sun 02 Jun 2013 10:08:56 AM EDT      Build Host: x86-023.build.eng.bos.redhat.com
Group       : System Environment/Base       Source RPM: xfsdump-3.0.4-3.el6.src.rpm
Size        : 766045                           License: GPL+
Signature   : RSA/8, Fri 23 Nov 2012 05:17:17 AM EST, Key ID 199e2f91fd431d51
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://oss.sgi.com/projects/xfs/
Summary     : Administrative utilities for the XFS filesystem
"

How reproducible:

consistent

Steps to Reproduce:
1. Install xfsdump from the scalable file system channel
2. Run 'xfsinvutil -i' as root

Actual results:

xfsinvutil: open of /var/lib/xfsdump/inventory/fstab failed.
open: No such file or directory
xfsinvutil: abnormal termination

Expected results:

The dump inventory management tool should enter interactive mode and allow you to view and manage your backups and their contents.

Comment 1 Eric Sandeen 2014-01-20 17:46:06 UTC
For starters, please open a case with your support folks to track & prioritize this properly.



If you have actually produced any dumps prior to the xfsinvutil command, then /var/lib/xfsdump/inventory/fstab should exist.

If it doesn't, then you have nothing to interact with in any case, and xfsinvutil -i will fail.  I suppose we could be a little more graceful about saying "you have no inventory" rather than emitting file open errors.

You're right, however, that the xfsdump package should own the /var/lib/xfsdump/inventory/ directory.  But that alone won't make "xfsinvutil -i" any happier until you've actually created an inventory.

-Eric

Comment 3 Paul Robert Marino 2014-01-20 19:00:02 UTC
I did create a case via a phone call which was supposed to be tied to this bug report but it doesn't appear to have shown up on the site yet.

That said I just confirmed It seems to work exactly as you said I was surprised by the fact that it created the directory /var/lib/xfsdump. That behavior strikes me as odd because I do not expect programs to create directories under /var/lib.
if that is the normal behavior thats fine although it raises the question in my mind if there might be any issues with selinux if I decided to setup a cron job to do a weekly backup.

Comment 4 Eric Sandeen 2014-01-20 19:02:19 UTC
Thanks for creating the case.

I just pushed a commit to Fedora Rawhide so that the xfsdump RPM creates & owns /var/lib/xfsdump/inventory - it is the right thing to do, but it won't change the user-visible behavior when there's no inventory to interact with.

Thanks,
-Eric

Comment 5 Eric Sandeen 2014-01-20 19:02:54 UTC
(We could include this fix in RHEL as well, if/when xfsdump gets another update)

Comment 7 XuWang 2014-09-02 07:10:04 UTC
I wrote a test case to check if the xfsdump include the directory "/var/lib/xfsdump/inventory" exists in xfsdump rpm. The problem reproduced on RHEL-5 and verified on RHEL6.6. Below is the job results.

reproduced:
:: [ 01:32:22 ] :: xfsdump version xfsdump-3.0.4-3.el6.x86_64
Setup result: PASS
:: [   FAIL   ] :: Command 'rpm -ql xfsdump | grep "^/var/lib/xfsdump/inventory$"' (Expected 0, got 1)

verified:
:: [   LOG    ] :: xfsdump version xfsdump-3.0.4-4.el6.x86_64
:: [   PASS   ] :: Command 'rpm -ql xfsdump | grep "^/var/lib/xfsdump/inventory$"' (Expected 0, got 0)


https://beaker.engineering.redhat.com/jobs/735662
https://beaker.engineering.redhat.com/jobs/735650

Comment 8 XuWang 2014-09-02 07:22:04 UTC
(In reply to XuWang from comment #7)
> I wrote a test case to check if the xfsdump include the directory
> "/var/lib/xfsdump/inventory" exists in xfsdump rpm. The problem reproduced
> on RHEL-5 and verified on RHEL6.6. Below is the job results.
> 
> reproduced:
> :: [ 01:32:22 ] :: xfsdump version xfsdump-3.0.4-3.el6.x86_64
> Setup result: PASS
> :: [   FAIL   ] :: Command 'rpm -ql xfsdump | grep
> "^/var/lib/xfsdump/inventory$"' (Expected 0, got 1)
> 
> verified:
> :: [   LOG    ] :: xfsdump version xfsdump-3.0.4-4.el6.x86_64
> :: [   PASS   ] :: Command 'rpm -ql xfsdump | grep
> "^/var/lib/xfsdump/inventory$"' (Expected 0, got 0)
> 
> 
> https://beaker.engineering.redhat.com/jobs/735662
> https://beaker.engineering.redhat.com/jobs/735650

fix the mistake of " RHEL-5 and verified on RHEL6.6. Below is the job results.",
it should be "RHEL6.5 and verified on RHEL6.6. Below is the job results.“

Comment 10 errata-xmlrpc 2014-10-14 07:50:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1565.html


Note You need to log in before you can comment on or make changes to this bug.