Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055638 - postgrey fails to start
Summary: postgrey fails to start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: postgrey
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1056364 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 16:18 UTC by Benjamin S. Scarlet
Modified: 2014-01-23 03:41 UTC (History)
3 users (show)

Fixed In Version: postgrey-1.34-11.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1058654 (view as bug list)
Environment:
Last Closed: 2014-01-22 03:12:18 UTC


Attachments (Terms of Use)

Description Benjamin S. Scarlet 2014-01-20 16:18:28 UTC
Description of problem:
The systemd script for postgrey is broken.

Version-Release number of selected component (if applicable):
postgrey-1.34-10.fc20.noarch

How reproducible:
every time

Steps to Reproduce:
1. systemctl start postgrey
2.
3.

Actual results:
postgrey does not start, with a complaint about line 15 in postgrey.service

Expected results:
postgrey should start


Additional info:
The line in postgrey.service which reads
 --greylist-text="Greylisted for %%s seconds"

should probably read
 "--greylist-text=Greylisted for %%s seconds" \

instead. Firstly, the backslash is needed as there is more of the command on the following line. Secondly, apparently systemd does not use a shell for command lines (reasonable); and consequently has its own rules for processing quotes in commands (an inevitable consequence, but unfortunate).

Comment 1 Fedora Update System 2014-01-21 02:45:49 UTC
postgrey-1.34-11.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/postgrey-1.34-11.fc20

Comment 2 Fedora Update System 2014-01-22 03:12:18 UTC
postgrey-1.34-11.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 3 Christopher Meng 2014-01-23 03:41:00 UTC
*** Bug 1056364 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.