Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055616 - Setting Qpid SSL protocol sets wrong variable
Summary: Setting Qpid SSL protocol sets wrong variable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z3
: 4.0
Assignee: Eric Harney
QA Contact: Dafna Ron
URL: https://code.engineering.redhat.com/g...
Whiteboard:
: 1045057 (view as bug list)
Depends On: 996766 1021536 1021537
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 15:51 UTC by Lon Hohberger
Modified: 2016-04-26 14:04 UTC (History)
15 users (show)

Fixed In Version: openstack-cinder-2013.2.1-1.el6ost
Doc Type: Bug Fix
Doc Text:
In the Openstack Block Storage service, there was an issue in setting qpid_protocol to ssl in the cinder.conf file in order to enable SSL. This resulted in the SSL not being enabled. With this bug fix, the correct variable is now set in the connection code to signal that SSL should be used. As a result, the SSL protocol is used in QPid when requested.
Clone Of: 1045057
Environment:
Last Closed: 2014-03-25 19:23:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1158807 None None None Never
Red Hat Product Errata RHBA-2014:0334 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix and Enhancement Advisory 2014-03-25 23:22:45 UTC
OpenStack gerrit 27075 None None None Never

Comment 2 Lon Hohberger 2014-01-20 15:53:38 UTC
*** Bug 1045057 has been marked as a duplicate of this bug. ***

Comment 3 Eric Harney 2014-01-21 16:08:58 UTC
Already in RHOS4 as this was in upstream 2013.2.

Comment 5 nlevinki 2014-03-19 07:21:15 UTC
We run sanity sutomation to verify the fix doesn't break the system and it is working correctly.
We found an issue with glance - packstack installation doesn't configure glance config file correctly regarding qpid ssl enable.
we will open a different ticket for this issue.

Comment 7 errata-xmlrpc 2014-03-25 19:23:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0334.html


Note You need to log in before you can comment on or make changes to this bug.