Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055588 - Use libosinfo for improved OS metadata (minimum disk size, ram, ...)
Summary: Use libosinfo for improved OS metadata (minimum disk size, ram, ...)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.0
Hardware: All
OS: All
medium
medium
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1165147 (view as bug list)
Depends On: 500320 1128621
Blocks: 1066293
TreeView+ depends on / blocked
 
Reported: 2014-01-20 15:10 UTC by Giuseppe Scrivano
Modified: 2015-03-05 10:03 UTC (History)
21 users (show)

Fixed In Version: virt-manager-1.1.0-2.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Important: if this rebase instead contains *only bug fixes,* or *only enhancements*, select the correct option from the Doc Type drop-down list. Rebase package(s) to version: Highlights, important fixes, or notable enhancements: OS dependent data is not maintained by virt-manager but it is read from libosinfo and this will allow better default values (RAM size, storage size, #CPUs) according to the OS chosen at installation time.
Clone Of: 500320
: 1066293 (view as bug list)
Environment:
Last Closed: 2015-03-05 10:03:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0427 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-03-05 14:38:46 UTC

Comment 2 zhengqin 2014-02-18 08:33:17 UTC
Could reproduce it on latest RHEL7 with virt-manager-0.10.0-16.el7.noarch.

Steps to Reproduce:
1. Create a VM for vista select OS type as "Windows" and version as"Microsoft Windows vista",forward to create a disk image.
2. the default disk image is 8G,but vista install needs at least 15G,if we create VM with the default setting,install will fail

Comment 5 CongDong 2014-09-10 08:25:38 UTC
I can reproduce with:
virt-manager-0.10.0-20.el7

VERIFY:
with  virt-manager-1.1.0-1.el7.noarch

Steps:
1. open virt-manager
#virt-manager
2. Click "Create  a new virtual machine"
3. In step 2, choose os type and version
os type: windows
version: Microsoft windows vista
4. in step 4, check the default disk size.


Result:
The default size is 40G

I test with win8 and win7 too, the default size is also 8G, it's not enough for the installation.

As the result, I think should update other os metadata

So, set ASSIGNED.

Comment 6 Giuseppe Scrivano 2014-09-10 12:23:52 UTC
please create a new bug and assign it to libosinfo.  This kind of problems should now be reported to libosinfo and not to virt-manager as libosinfo is the owner of the OS database.

virt-manager is only responsible for reading correctly this information from libosinfo, you can check if it is correct by looking at the file /usr/share/libosinfo/db/oses/windows.xml

Comment 7 CongDong 2014-09-12 03:35:07 UTC
(In reply to Giuseppe Scrivano from comment #6)
> please create a new bug and assign it to libosinfo.  This kind of problems
> should now be reported to libosinfo and not to virt-manager as libosinfo is
> the owner of the OS database.
> 
> virt-manager is only responsible for reading correctly this information from
> libosinfo, you can check if it is correct by looking at the file
> /usr/share/libosinfo/db/oses/windows.xml

I check the file, but the storage is not the default size in virt-manager:
# cat /usr/share/libosinfo/db/oses/windows.xml
...
  <os id="http://microsoft.com/win/8">
    <short-id>win8</short-id>
...
    <resources arch="i686">
      <minimum>
        <cpu>1000000000</cpu>
        <n-cpus>1</n-cpus>
        <ram>1073741824</ram>
        <storage>17179869184</storage>
      </minimum>
    </resources>

    <resources arch="x86_64">
      <minimum>
        <cpu>1000000000</cpu>
        <n-cpus>1</n-cpus>
        <ram>2147483648</ram>
        <storage>21474836480</storage>
...

As the result win8 storage need 16G for win8 and 20G for x86_64. 
But in virt-manager the default is still 8G for win8.
Do you think it's still a problem for libosinfo?

Comment 8 Giuseppe Scrivano 2014-09-12 08:32:20 UTC
virt-manager reads the "recommended" resources block and win8 misses this information.  I'll propose a change in virt-manager to consider the "minimum" information where the "recommended" is missing.

Comment 9 Giuseppe Scrivano 2014-09-12 09:04:35 UTC
I've proposed a patch upstream to consider "minimum" resources when "recommended" is missing:

https://www.redhat.com/archives/virt-tools-list/2014-September//msg00092.html

Comment 12 CongDong 2014-09-18 07:54:43 UTC
I re-test with :
virt-manager-1.1.0-2.el7

Steps are same with comment 5.

virt-manager reads the recommended default.
If the recommended is missing, the value is double of the minimum,
test with win2k3r2, win2k3, win7, win8 and win8.1

Also test rhel7 and rhel6, default value is same with usr/share/libosinfo/db/oses/rhel.xml.

As this result, move to verify.

Comment 13 Giuseppe Scrivano 2014-11-18 13:12:17 UTC
*** Bug 1165147 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2015-03-05 10:03:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0427.html


Note You need to log in before you can comment on or make changes to this bug.