Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055524 - [RFE] qemu-ga installed by default on Linux Guests with ovirt-guest-agent
Summary: [RFE] qemu-ga installed by default on Linux Guests with ovirt-guest-agent
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-guest-agent
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks: 1057999
TreeView+ depends on / blocked
 
Reported: 2014-01-20 13:33 UTC by Vinzenz Feenstra [evilissimo]
Modified: 2014-03-31 15:03 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.4.0-ga
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1057999 (view as bug list)
Environment:
Last Closed: 2014-03-31 15:03:57 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23443 None None None Never

Description Vinzenz Feenstra [evilissimo] 2014-01-20 13:33:50 UTC
In order to support https://bugzilla.redhat.com/show_bug.cgi?id=1054231 we need to add the qemu-guest-agent by default to support freezing and thawing the filesystems.

The guest agent will implement a dependency on the package so it is installed when the ovirt-guest-agent is installed.

Comment 1 Vinzenz Feenstra [evilissimo] 2014-01-20 14:30:05 UTC
Merged to u/s master as http://gerrit.ovirt.org/gitweb?p=ovirt-guest-agent.git;a=commit;h=52b97cfbd5f1a4378b0be168ffd8293e29f99f46

Comment 2 Sandro Bonazzola 2014-01-23 08:54:39 UTC
Verified using http://evilissimo.fedorapeople.org/repos/ovirt-guest-agent/ovirt-3.4/beta1/
on CentOS 6.5, Fedora 19 and Fedora 20.

Comment 3 Sven Kieske 2014-03-18 10:31:12 UTC
Well this can bite you, if you want to use the agent on ubuntu and debian.
I didn't find any qemu-ga packages there.
(ubuntu 12.04 and debian 7 aka wheezy).
They both work fine with the ubuntu ppa for 12.04. though.
Can someone point me in the right direction for getting the qemu-ga for ubuntu/ debian?

Comment 4 Sandro Bonazzola 2014-03-31 15:03:57 UTC
This is an automated message: moving to Closed CURRENT_RELEASE since oVirt 3.4.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.