Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055517 - log-collector accesses /api instead of /ovirt-engine/api
Summary: log-collector accesses /api instead of /ovirt-engine/api
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-logcollector
Version: 3.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Sandro Bonazzola
QA Contact: Petr Beňas
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 13:15 UTC by Yedidyah Bar David
Modified: 2015-01-04 23:05 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:32:06 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23935 None None None Never
oVirt gerrit 24156 None None None Never
Red Hat Bugzilla 1059692 None None None Never

Internal Links: 1059692

Description Yedidyah Bar David 2014-01-20 13:15:50 UTC
Description of problem:

Following bz 961677 the REST API should be accessed using /ovirt-engine/api and not /api.

Version-Release number of selected component (if applicable):

3.4

How reproducible:

Always

Steps to Reproduce:
1. engine-log-collector collect
2.
3.

Actual results:

Fails connecting to the engine with:
ERROR: Unable to connect to REST API.  Reason: Bad Request

Expected results:

Should not fail

Additional info:

Comment 1 Alon Bar-Lev 2014-01-20 13:20:04 UTC
but we do support both /api and /ovirt-engine/api if there is a problem we need to know what it is.

anyway, stupid question... why is log collector using the api?

Comment 2 Yedidyah Bar David 2014-01-20 14:38:01 UTC
(In reply to Alon Bar-Lev from comment #1)
> but we do support both /api and /ovirt-engine/api if there is a problem we
> need to know what it is.

Right, sorry. There is no problem. Still we might want to change it to use /ovirt-engine/api, but it currently fails for me for some other reason. I'll check and might open another bug.

> 
> anyway, stupid question... why is log collector using the api?

To get a list of the hosts to collect logs from.

Comment 3 Alon Bar-Lev 2014-01-20 14:41:44 UTC
(In reply to Yedidyah Bar David from comment #2)
> > 
> > anyway, stupid question... why is log collector using the api?
> 
> To get a list of the hosts to collect logs from.

hmmm.... won't it easier to access the database directly? then it can run if engine is down and no need for application admin password...

Comment 4 Itamar Heim 2014-01-26 08:11:36 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 5 Sandro Bonazzola 2014-02-06 12:40:52 UTC
merged on upstream master and 3.4.0 branch.

Comment 6 Petr Beňas 2014-02-25 12:27:24 UTC
Basic sanity test. Verified engine-log-collector collect works in ovirt-log-collector-3.4.0-0.5.beta3.el6.noarch.

Comment 7 Sandro Bonazzola 2014-03-31 12:32:06 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.