Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055511 - Race condition when updating dependent path services
Summary: Race condition when updating dependent path services
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: EAP 6.3.0
Assignee: Kabir Khan
QA Contact: Petr Kremensky
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks: 970249
TreeView+ depends on / blocked
 
Reported: 2014-01-20 12:59 UTC by Jan Martiska
Modified: 2015-03-11 09:30 UTC (History)
2 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 06:02:15 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBQA-8832 Critical Closed PathsTestCase intermittent failure 2015-03-11 08:40:40 UTC

Description Jan Martiska 2014-01-20 12:59:46 UTC
The test org.jboss.as.controller.services.path.PathsTestCase#testChangeDependentServiceNotificationIsCascaded intermittently fails (quite rarely). It is because of a race condition when updating path services.

Scenario:
- have an AbsolutePathService add1
- create a RelativePathService add2 which is relative-to add1 
- change the path in add1
- resolve the path of add2 (method getValue)

This will sometimes fail and the last step will yield add2 path relative to the OLD value of add1, because the getValue() method of AbstractPathService might get called BEFORE the start() method finishes, so the private "path" field will have the old value which was resolved against add1 earlier.

You can reproduce this easily using PathsTestCase#testChangeDependentServiceNotificationIsCascaded if you just run the test repeatedly in an infinite loop (to speed it up, enclose everything except the first line in a while(true) and append an operation to change add1's path to "xyz" at the end of the loop).

Comment 1 Petr Kremensky 2014-07-28 06:02:15 UTC
I was able to re-reproduce this with 6.2.0.GA, but cannot reproduce with 6.3.0.ER10 thus closing this as fixed.

Comment 2 JBoss JIRA Server 2015-03-11 08:40:42 UTC
Jan Martiska <jmartisk@redhat.com> updated the status of jira JBQA-8832 to Closed


Note You need to log in before you can comment on or make changes to this bug.