Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055492 - Puppet doesn't register the Cinder in endpoints in the CC's database
Summary: Puppet doesn't register the Cinder in endpoints in the CC's database
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 4.0
Hardware: All
OS: All
urgent
urgent
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Jiri Stransky
QA Contact: Ami Jeain
URL:
Whiteboard: storage
Depends On:
Blocks: 1064889
TreeView+ depends on / blocked
 
Reported: 2014-01-20 11:53 UTC by Yogev Rabl
Modified: 2014-09-08 05:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-06 16:37:44 UTC


Attachments (Terms of Use)

Description Yogev Rabl 2014-01-20 11:53:28 UTC
Description of problem:
At the moment, the Controller host group configures the Cinder locally, together with all the other services (apart from Nova compute). With that the all the references to the Cinder server in the MySQL database are directed to the localhost (the controller). 

The puppet that installs the block storage host group should change the old references in the database to the new Cinder server. 
For my knowledge, the change should be in the keystone database, in the endpoint table. The lines referencing to the Cinder are: 

+----------------------------------+----------------------------------+-----------+-----------+----------------------------------+-------------------------------------------------+-------+        
| id                               | legacy_endpoint_id               | interface | region    | service_id                       | url                                             | extra |        
+----------------------------------+----------------------------------+-----------+-----------+----------------------------------+-------------------------------------------------+-------+        
| 07b48f53fc984a4d9cb2ae42ac845187 | f4277799a9f147e285e7857a5715cb30 | public    | RegionOne | f4a56ae205c14ed4853e962b668c5f64 | http://<CinderServer>:8080/v1/AUTH_%(tenant_id)s | {}    |        
| 21c0ca3f71374c77aaaa73acb14f0103 | 15d8bfa4d04c476796bf4f7c17b497d9 | public    | RegionOne | 7cda235d08764b7f942ad73d4ba5ff1a | http://<CinderServer>:8776/v1/%(tenant_id)s      | {}    |        
| 2ef27a69d4904ff28e021b2cdc191699 | 15d8bfa4d04c476796bf4f7c17b497d9 | admin     | RegionOne | 7cda235d08764b7f942ad73d4ba5ff1a | http://<CinderServer>:8776/v1/%(tenant_id)s      | {}    |        
| 3f7098ae582c4bd7907b939823a7c349 | 67a2b418f50a44ea893a7f7ca9c26322 | admin     | RegionOne | c23d6a1da4f4458d8dc24ab4433654b7 | http://<CinderServer>:8776/v2/%(tenant_id)s      | {}    |        
| 47fe3d86a3f740c5956f0e06a9462d40 | 67a2b418f50a44ea893a7f7ca9c26322 | public    | RegionOne | c23d6a1da4f4458d8dc24ab4433654b7 | http://<CinderServer>:8776/v2/%(tenant_id)s      | {}    |
| 6ef8d60dba004f2ea851e27b7c9a1184 | 37416da3eb3e453babbddcd966f00e63 | internal  | RegionOne | badab92972d848249a1702733092a103 | http://<CinderServer>:8080                       | {}    |
| 8a1b8dbec4e14530a36c628e38c8bf81 | 15d8bfa4d04c476796bf4f7c17b497d9 | internal  | RegionOne | 7cda235d08764b7f942ad73d4ba5ff1a | http://<CinderServer>:8776/v1/%(tenant_id)s      | {}    |
| 932a36f241c14abaacd2d54ce8845b31 | 67a2b418f50a44ea893a7f7ca9c26322 | internal  | RegionOne | c23d6a1da4f4458d8dc24ab4433654b7 | http://<CinderServer>:8776/v2/%(tenant_id)s      | {}    |
| a1e1db5bd2f7441d99718f71dd750282 | f4277799a9f147e285e7857a5715cb30 | internal  | RegionOne | f4a56ae205c14ed4853e962b668c5f64 | http://10.35.161.153:8080/v1/AUTH_%(tenant_id)s | {}    |
| a38737527645448498db1d028049ec87 | f4277799a9f147e285e7857a5715cb30 | admin     | RegionOne | f4a56ae205c14ed4853e962b668c5f64 | http://<CinderServer>:8080/                      | {}    |
| a8003de2e47d4389b0235854793ecb0a | 37416da3eb3e453babbddcd966f00e63 | public    | RegionOne | badab92972d848249a1702733092a103 | http://<CinderServer>:8080                       | {}    |
| ed73389021ba443486b5c00e1bb695fd | 37416da3eb3e453babbddcd966f00e63 | admin     | RegionOne | badab92972d848249a1702733092a103 | http://<CinderServer>:8080                       | {}    |
+----------------------------------+----------------------------------+-----------+-----------+----------------------------------+-------------------------------------------------+-------+

Comment 4 Jiri Stransky 2014-06-06 16:37:44 UTC
The Block Storage host group only deploys cinder-volume service, not cinder-api or cinder-scheduler. The endpoint in keystone should point to the host where cinder-api is running, so it should point to the Controller even if we use the Block Storage host group to scale out the cinder-volume service. If i understand the report correctly, i'd say this is not a bug.


Note You need to log in before you can comment on or make changes to this bug.