Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055474 - [RHSC] - Mouse hovering on rebalance icon when rebalance is stopped from cli , needs to be changed.
Summary: [RHSC] - Mouse hovering on rebalance icon when rebalance is stopped from cli ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: 2.1
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
: RHGS 3.1.0
Assignee: anmol babu
QA Contact: storage-qa-internal@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1202842
TreeView+ depends on / blocked
 
Reported: 2014-01-20 10:48 UTC by RamaKasturi
Modified: 2015-07-29 05:25 UTC (History)
8 users (show)

Fixed In Version: rhsc-3.1.0-57
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-29 05:25:20 UTC


Attachments (Terms of Use)
Attaching the screenshot for the same. (deleted)
2014-01-20 10:48 UTC, RamaKasturi
no flags Details
Attaching screenshot for the message which gets displayed when rebalance is stopped from CLI (deleted)
2015-05-28 07:26 UTC, RamaKasturi
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1494 normal SHIPPED_LIVE Red Hat Gluster Storage Console 3.1 Enhancement and bug fixes 2015-07-29 09:24:02 UTC
oVirt gerrit 34062 master MERGED webadmin : Changed tooltip for UNKNOWN async task status Never
oVirt gerrit 40480 ovirt-engine-3.5-gluster MERGED webadmin : Changed tooltip for UNKNOWN async task status Never

Description RamaKasturi 2014-01-20 10:48:22 UTC
Created attachment 852709 [details]
Attaching the screenshot for the same.

Description of problem:
when rebalance is stopped from cli, mouse hovering on the icon gives a message saying "Rebalance in progress, but status unknown. Unable to fetch the status at the moment."

Version-Release number of selected component (if applicable):
rhsc-2.1.2-0.33.el6rhs.noarch

How reproducible:
Always

Steps to Reproduce:
1. create a distribute volume and start rebalance.
2. Now go the gluster cli and run the command "gluster vol rebalance <vol_Name> stop".
3. Now mouse hover on the rebalance icon in the activities column.

Actual results:
It gives a tool tip saying "Rebalance in progress, but status unknown. Unable to fetch the status at the moment."

Expected results:
It should say that "Rebalance is stopped from CLI"

Additional info:

Comment 2 anmol babu 2014-10-13 09:25:02 UTC
As the task details are not available to engine sync job once the task is stopped from cli,refactoring the tooltip message to say :
"Rebalance status could not be determined" in case of rebalance.
and 
"Remove brick status could not be determined" in case of remove-brick.

Comment 4 RamaKasturi 2015-05-22 07:31:14 UTC
please provide the fixed in version

Comment 5 RamaKasturi 2015-05-28 07:25:09 UTC
Verified in the build rhsc-3.1.0-0.57.master.el6.noarch.

When user stops rebalance from CLI, status in UI will be changed to UNKNOWN with a question mark and mouse hovering on that says "Rebalance status could not be determined". Attaching screenshot for the same.

Comment 6 RamaKasturi 2015-05-28 07:26:17 UTC
Created attachment 1031062 [details]
Attaching screenshot for the message which gets displayed when rebalance is stopped from CLI

Comment 8 errata-xmlrpc 2015-07-29 05:25:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1494.html


Note You need to log in before you can comment on or make changes to this bug.