Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055466 - booting win2012r2 guest would black screen with error code 0x000000c4
Summary: booting win2012r2 guest would black screen with error code 0x000000c4
Keywords:
Status: CLOSED DUPLICATE of bug 1044979
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Ronen Hod
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 10:31 UTC by xhan
Modified: 2014-12-15 00:54 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-22 06:57:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot-1 (deleted)
2014-01-20 10:31 UTC, xhan
no flags Details

Description xhan 2014-01-20 10:31:09 UTC
Created attachment 852678 [details]
screenshot-1

Description of problem:

In RHEL7.0 host, boot win2012r2 guest. Guest would go to black screen with the error code: 0x000000c4. The screen shot is as file screenshot-1.

Version-Release number of selected component (if applicable):
kernel-3.10.0-69.el7.x86_64
qemu-kvm-rhev-1.5.3-36.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot win2012r2 guest
qemu \
    -S  \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -M pc  \
    -nodefaults  \
    -vga std  \
    -monitor stdio \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20140120-181307-tQEO7hpz,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20140120-181307-tQEO7hpz,path=/tmp/seabios-20140120-181307-tQEO7hpz,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20140120-181307-tQEO7hpz,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=04 \
    -drive id=drive_image1,if=none,cache=unsafe,snapshot=off,aio=native,file=data/images/win2012r2-64-virtio.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1 \
    -device virtio-net-pci,mac=9a:08:09:0a:0b:0c,id=idcawy4P,netdev=idI43hgO,bus=pci.0,addr=05  \
    -netdev tap,id=idI43hgO,vhost=on,script=/etc/qemu-ifup  \
    -m 8192  \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2  \
    -cpu 'Conroe',+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=data/isos/windows/winutils.iso \
    -device scsi-cd,id=cd1,drive=drive_cd1 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :1  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off \
    -enable-kvm

2. watch the vnc booting screen
3.

Actual results:
guest goes into black screen and repeated the booting process
The error code is 0x000000c4 as the screenshot-1

Expected results:
Guest can boot successfully.

Additional info:
cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 15
model name	: Intel(R) Xeon(R) CPU            5130  @ 2.00GHz
stepping	: 11
microcode	: 0xbc
cpu MHz		: 1995.118
cache size	: 4096 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx tm2 ssse3 cx16 xtpr pdcm dca lahf_lm dtherm tpr_shadow vnmi flexpriority
bogomips	: 3990.23
clflush size	: 64
cache_alignment	: 64
address sizes	: 38 bits physical, 48 bits virtual
power management:

Comment 2 Ronen Hod 2014-01-20 15:08:06 UTC
xhan,

Please try the hotfix from http://support.microsoft.com/kb/2816159
(actually, I do not know if it can be applied if you cannot boot).
Does it mean that 2012R2 never managed to boot on RHEL7? Maybe we need to somehow bisect, since it worked on RHEL6.

Comment 3 Yan Vugenfirer 2014-01-20 15:25:42 UTC
Very strange bug check code.

1. First 0xC4 is reserved for driver verifier. Did you turned it on? Was this image ever used for HCK certification?


2. Parameter 1 equal to 0x91 of 0xC4 bug check means - "The driver switched stacks using a method that is not supported by the operating system. The only supported way to extend a kernel mode stack is by using KeExpandKernelStackAndCallout."  - http://msdn.microsoft.com/en-us/library/windows/hardware/ff560187(v=vs.85).aspx

Do you have anti-viruses installed on this image? 
Is this image clean or did you installed some SW on it before testing?

3. Please try to boot with safe mode and fetch the memory crash dump from the guest.

Best regard,
Yan.

Comment 4 Mike Cao 2014-01-22 02:27:39 UTC
(In reply to Ronen Hod from comment #2)
> xhan,
> 
> Please try the hotfix from http://support.microsoft.com/kb/2816159
> (actually, I do not know if it can be applied if you cannot boot).
> Does it mean that 2012R2 never managed to boot on RHEL7? Maybe we need to
> somehow bisect, since it worked on RHEL6.

I just manage to finish Balloon HCK tests on RHEL7 host including win2k12R2 ,no such issue found

Comment 5 CongLi 2014-01-22 02:45:33 UTC
(In reply to xhan from comment #0)

>     -cpu 'Conroe',+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic \

> Actual results:
> guest goes into black screen and repeated the booting process
> The error code is 0x000000c4 as the screenshot-1


Maybe it's related to the cpu flags for this bug is similar to 
Bug 1044979 - win8.1.x86_64 / win2012r2 guest will circling reboot when boot with -cpu 'Conroe' 

https://bugzilla.redhat.com/show_bug.cgi?id=1044979

Thanks,
Cong

Comment 7 xhan 2014-01-22 06:57:14 UTC
Change to -cpu 'host', then boot win2012r2 successfully.

*** This bug has been marked as a duplicate of bug 1044979 ***


Note You need to log in before you can comment on or make changes to this bug.