Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055448 - cannot install remote gluster storage for cinder with foreman
Summary: cannot install remote gluster storage for cinder with foreman
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 4.0
Hardware: All
OS: All
urgent
high
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Gilles Dubreuil
QA Contact: Ami Jeain
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 09:53 UTC by Yogev Rabl
Modified: 2016-04-26 14:30 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-15 06:01:52 UTC


Attachments (Terms of Use)

Description Yogev Rabl 2014-01-20 09:53:29 UTC
Description of problem:
When installing the Cinder with the GlusterFS as a backend in packstack it has the path of the GlusterFS share in the answer file. The Foreman installer should have the same parameter available. 
The path of the share should be configured in the file: /etc/cinder/gluster_share.conf .

Comment 2 Yogev Rabl 2014-01-20 10:20:24 UTC
And the new value of the 'cinder_gluster_peers' is going back to the default.

Comment 3 Jason Guiditta 2014-01-22 20:10:21 UTC
Yogev, can you please provide more detail of what you have tried to set up here?  Is this a Controller (Nova or Neutron) that you were trying to configure? Is it the 'lvm block storage' host group?  I see the latter has a _peers param, but not the former. Neither seems to have a _path param, so this looks like a valid request, just want to better understand your test setup.

Comment 4 Yogev Rabl 2014-02-13 12:41:12 UTC
I've tried to setup a Cinder with remote storage, GlusterFS, to be precise. 
The Cinder, as a service, can be installed with the Nova, the Neutron or as a stand alone, it is not a part of the CC. 
This is the setup I tried to install, from the packstack answer file:

# The Cinder backend to use, valid options are: lvm, gluster, nfs
CONFIG_CINDER_BACKEND=gluster
 
# A single or comma separated list of gluster volume shares to mount,
# eg: ip-address:/vol-name
CONFIG_CINDER_GLUSTER_MOUNTS='10.35.161.158:/Dafna_cougar'

The first is the type of backend. The second is the list of the mounts that should be in the file I've specified.

Comment 5 Mike Orazi 2014-02-14 02:34:47 UTC
Yogev,

I think we understand what you are trying to accomplish from a packstack perspective.  What I think we need to understand is what you did in foreman to try to get there.  (Did you install the LVM host group or a controller?  In either case, what values did you pass in to the cinder/gluster params?)

Comment 6 Yogev Rabl 2014-03-20 13:51:38 UTC
My steps were:
1. go to the LVM Block Storage host group and change the following parameters (the same can apply for the parameters in the Controller host group):

- cinder_backend_gluster: true
- cinder_gluster_peers: [<gluster storage's hostanme>]
- cinder_gluster_volume: <volume name>
- controller_priv_host: <CC IP address>
- mysql_host: <CC IP address>
- qpid_host: <CC IP address>

2. Set the host group in the host's configuration.

Comment 16 Arthur Berezin 2014-04-24 11:22:13 UTC
Deploying Cinder with Gluster backend as backend is supported and should function properly. There's an existing BZ#1062693 for deploying libgfapi for Gluster backend, is this BZ opened on fuse client for Gluster ?

Comment 18 Mike Orazi 2014-06-06 15:22:53 UTC
Can you confirm the present state of this in HA controller, non-HA controller, and blocker storage host group?

Comment 19 Gilles Dubreuil 2014-06-06 23:20:25 UTC
For RHOS4 target A5 - non HA: 

1. There are commits waiting to be backported from Icehouse(Quickstack) for the gluster servers part, please see BZ#1073628

2. There Pull Requests waiting to be merged into Icehouse(Quickstack) and then to be backported, 
- https://github.com/redhat-openstack/astapor/pull/229
- https://github.com/redhat-openstack/astapor/pull/251

Comment 21 Yogev Rabl 2014-07-08 10:32:24 UTC
Arthur, this bug relates to the inconsistency of the parameters names of the Gluster's configuration settings between Packstack and the Foreman.

Comment 22 Gilles Dubreuil 2014-07-15 06:01:52 UTC
Packstack and Quickstack have different deployment scopes and are using totally independent set of options/parameters.

That said a 'cinder_gluster_shares' option exists for latest Quickstack.

Since this ticket was lodge for Packstack and there is no issue I'm closing it.
Please feel free to comment and reopen if needed.


Note You need to log in before you can comment on or make changes to this bug.