Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055446 - Evolution fails to remember passwords after upgrade
Summary: Evolution fails to remember passwords after upgrade
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 20
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 09:51 UTC by markm
Modified: 2014-01-26 10:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-20 21:55:47 UTC


Attachments (Terms of Use)

Description markm 2014-01-20 09:51:58 UTC
Description of problem:

I've upgraded Fedora 19 to 20 via yum, after that evolution lost its passwords and does not save them to keyring. It's a bit of an issue as I use 2-step verification with gmail, hence I need to re-create password every time I start evolution.

Version-Release number of selected component (if applicable):

$ rpm -qa | grep evolution
evolution-data-server-3.10.3-1.fc20.x86_64
evolution-3.10.3-1.fc20.x86_64

How reproducible:

Allways, on two different computers


Steps to Reproduce:
1. Fedora 19, add email account to evolution
2. upgrade to Fedora 20, reboot
3. Run evolution

Actual results:

Evolution asks about password every time it starts

Expected results:

Evolution to remember passwords

Additional info:

Comment 1 Milan Crha 2014-01-20 12:46:35 UTC
Thanks for a bug report. It sounds more like an issue with gnome-keyring, than with evolution itself. Could you install Seahorse, install it, and verify that your Default keyring is unlocked? Use View->By Keyring menu option in Seahorse (Passwords and Keys) to see your configured keayrings. I have only one keyring, named 'Login', configured.

Comment 2 markm 2014-01-20 21:55:47 UTC
Ok, that's weird - just got back home, started my laptop and evolution, no question asked about password. Looking at the passwords I have just one keyring "Login" and it's unlocked.

Thanks for a quick reply! Closing as NOT A BUG

Comment 3 Milan Crha 2014-01-21 07:34:17 UTC
I just recalled there is sometimes an issue to get stored password, where usually a restart of evolution-source-registry process makes it work again. It's quite rare, and I was not able to reproduce it myself on will. Thus maybe you faced just that and the machine restart helped to cure the issue.

Comment 4 markm 2014-01-26 10:28:46 UTC
(In reply to Milan Crha from comment #3)
> I just recalled there is sometimes an issue to get stored password, where
> usually a restart of evolution-source-registry process makes it work again.
> It's quite rare, and I was not able to reproduce it myself on will. Thus
> maybe you faced just that and the machine restart helped to cure the issue.

Maybe - in fact, I had similar issue when I upgraded to Fedora 18 I remember now. Maybe it's related to the upgrade? Thanks for a tip, if I face it again, I'll try to restart evolution-source-registry process and check if it helps.


Note You need to log in before you can comment on or make changes to this bug.