Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055384 - During upgrade Rhevm-doc is not updated to latest version and remains with old version
Summary: During upgrade Rhevm-doc is not updated to latest version and remains with ol...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: distribution
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Kiril Nesenko
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On:
Blocks: 1067411 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-01-20 07:16 UTC by meital avital
Modified: 2014-09-18 12:24 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1067411 (view as bug list)
Environment:
Last Closed:
oVirt Team: ---


Attachments (Terms of Use)

Description meital avital 2014-01-20 07:16:01 UTC
Description of problem: During upgrade Rhevm-doc is not updated to latest version and remains with old version
rhevm-doc not updated in upgrade. for example is25 to is32.2

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.45.el6ev

How reproducible:
Always

Steps to Reproduce:
1.both old repo and new repo (rhevm) are availible
2.yum update rhevm-setup
3.run engine-setup

Actual results:
rhevm-doc-3.3.0-1.el6eng.noarch

Expected results:
rhevm-doc-3.3.0-3.el6eng.noarch

Comment 3 Yedidyah Bar David 2014-02-06 11:05:58 UTC
I personally think this is not a bug. There is no problem having any of them installed. If I, as a user, want to look at previous version of the docs, and I want to do that by installing (or keeping) the older rpm, why shouldn't I? If I want the newest I can simply 'yum update'.

Comment 5 Eyal Edri 2014-02-06 13:10:17 UTC
docs are usually only built for GA, do i don't expect this spec update to be done too much on z-streams.

Comment 6 Sandro Bonazzola 2014-02-06 14:37:23 UTC
(In reply to Eyal Edri from comment #5)
> docs are usually only built for GA, do i don't expect this spec update to be
> done too much on z-streams.

So can you update comps.xml for including docs?

Comment 7 Sandro Bonazzola 2014-02-06 14:45:28 UTC
Moving to Kiril

Comment 9 Jay Greguske 2014-02-09 21:04:59 UTC
Sure. Can you send me the current groups.xml you guys keep? Should I take the one from IS32.2?

Comment 11 Kiril Nesenko 2014-02-10 08:48:23 UTC
(In reply to Jay Greguske from comment #9)
> Sure. Can you send me the current groups.xml you guys keep? Should I take
> the one from IS32.2?

Hello Jay,
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE comps PUBLIC "-//Red Hat, Inc.//DTD Comps info//EN" "comps.dtd">
<comps>

  <group>
   <id>rhevm33</id>
   <default>false</default>
   <uservisible>true</uservisible>
   <display_order>1024</display_order>
   <name>RHEV Manager</name>
   <description></description>
    <packagelist>
      <packagereq type="mandatory">otopi</packagereq>
      <packagereq type="mandatory">ovirt-host-deploy</packagereq>
      <packagereq type="mandatory">redhat-support-plugin-rhev</packagereq>
      <packagereq type="mandatory">rhevm</packagereq>
      <packagereq type="mandatory">rhevm-backend</packagereq>
      <packagereq type="mandatory">rhevm-config</packagereq>
      <packagereq type="mandatory">rhevm-dbscripts</packagereq>
      <packagereq type="mandatory">rhevm-doc</packagereq>
      <packagereq type="mandatory">rhevm-doc-ja-JP</packagereq>
      <packagereq type="mandatory">rhevm-genericapi</packagereq>
      <packagereq type="mandatory">rhevm-image-uploader</packagereq>
      <packagereq type="mandatory">rhevm-iso-uploader</packagereq>
      <packagereq type="mandatory">rhevm-log-collector</packagereq>
      <packagereq type="mandatory">rhevm-notification-service</packagereq>
      <packagereq type="mandatory">rhevm-restapi</packagereq>
      <packagereq type="mandatory">rhevm-setup</packagereq>
      <packagereq type="mandatory">rhevm-tools-common</packagereq>
      <packagereq type="mandatory">rhevm-userportal</packagereq>
      <packagereq type="mandatory">rhevm-webadmin-portal</packagereq>
    </packagelist>
  </group>
</comps>

- Kiril

Comment 12 Kiril Nesenko 2014-02-10 08:50:44 UTC
Hello Chris,

Can you ack the bz if relevant ?

- Kiril

Comment 14 Kiril Nesenko 2014-02-10 21:34:53 UTC
Meital, please ack.

Comment 19 Alon Bar-Lev 2014-02-14 20:58:59 UTC
bad robot

Comment 28 Jiri Belka 2014-06-02 08:56:22 UTC
ok, av9.4

# repoquery -g --grouppkgs=all -l rhevm34 --repofrompath=av9.4-el6,http://10.34.63.204/repo-tlv-builds/av9.4/el6/
ovirt-host-deploy
rhevm
rhevm-cli
rhevm-log-collector
redhat-support-plugin-rhev
rhevm-branding-rhev
otopi
rhevm-image-uploader
rhevm-doc
rhevm-iso-uploader

Comment 29 Itamar Heim 2014-06-12 14:07:25 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.