Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055340 - As of Jan 15, can no longer assign the Euro symbol to a key
Summary: As of Jan 15, can no longer assign the Euro symbol to a key
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-tweak-tool
Version: 20
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mohamed El Morabity
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 03:52 UTC by Leslie Satenstein
Modified: 2014-09-22 22:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-22 22:44:48 UTC


Attachments (Terms of Use)

Description Leslie Satenstein 2014-01-20 03:52:23 UTC
Description of problem:
Initial F20 release allowed assigning the Euro symbol to a key. (example, the E, 4 or 5 key) It worked.

Version-Release number of selected component (if applicable):

Maintenance was done sometime after Jan 1, 2014 where the Euro Symbol cannot be assigned.
If however, Tweak->typing->Miscellaneous compatibility->Enable extra typographic characters, Then the euro appears, but I lose the Tilde character (as in ~

How reproducible:

start Gnome-tweak-tool and select typing, The adding currency selection fails to produce any result.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

If I chose the E key (to match the keyboards sold in Quebec Canada), then I expect to be able to enter the euro key on doing right-alt-char-E

Tried this with different Gnome options, and different keyboards. My system is the 64bit Fed20. 

If I do a clean installation, (from ISO file, it works, until updates are applied). An update is in error.  

Additional info:

Comment 1 Mohamed El Morabity 2014-01-20 13:44:18 UTC
GNOME Tweak Tool hasn't been updated since the Fedora 20 release. It's very likely that the issue comes from another GNOME component updated recently.

Could you have a look at the /var/log/yum.log file, so you can get the list of all updated packages since January 15?

Comment 2 Leslie Satenstein 2014-03-25 22:23:44 UTC
Mohamed,
Is Fedora 20 purely an American Linux software.  If it is geared to the the world at large, then the Gnome Tweak option to assign the EuroSign to a key, must work, as it does in Fedora19.

What does not work is the recognition that it only works if the keyboard is the US layout and no other,

The other aspect that does not work, is that while I edited 
/usr/var/X11/xkb/symbols/ca  

to include the Euro symbol permenantly, that change does not migrate to the tty CA layout.  

In otherwords, by Wont Fix, are you advertising to the community that only the USA keyboard can have the optional Euro symbol.  The Gnome Tweak terminal option works with that US layout.

Any chance it will be fixed for Fedora20.

Oh, by the way, it works with Ubuntu, Debian Wheezy, and Mint16 and Fedora19.

Comment 3 Mohamed El Morabity 2014-03-25 22:39:36 UTC
(In reply to Leslie Satenstein from comment #2)
> Mohamed,
> Is Fedora 20 purely an American Linux software.  If it is geared to the the
> world at large, then the Gnome Tweak option to assign the EuroSign to a key,
> must work, as it does in Fedora19.
> 
> What does not work is the recognition that it only works if the keyboard is
> the US layout and no other,
> 
> The other aspect that does not work, is that while I edited 
> /usr/var/X11/xkb/symbols/ca  
> 
> to include the Euro symbol permenantly, that change does not migrate to the
> tty CA layout.  
> 
> In otherwords, by Wont Fix, are you advertising to the community that only
> the USA keyboard can have the optional Euro symbol.  The Gnome Tweak
> terminal option works with that US layout.
> 
> Any chance it will be fixed for Fedora20.
> 
> Oh, by the way, it works with Ubuntu, Debian Wheezy, and Mint16 and Fedora19.
For your information, I'm French... And I'm hapilly using a good-old AZERTY keyboard with an € key under GNOME ;).

I closed this bug report because I asked you in comment #1 a few information to analyse what changed on your system since 15 January, and maybe assign this report to the right person if needed. Unfortunately, I'm still waiting for 2 months :(.

I'm anyway still willed to help you if this problem still occurs, and my previous question is still open ;).

Comment 4 Leslie Satenstein 2014-09-22 22:44:48 UTC
Please Close,

Euro Symbol gets assigned after software update.


Note You need to log in before you can comment on or make changes to this bug.