Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055334 - Installing RHEL guests takes too long (more than 50 minutes) in some scenarios
Summary: Installing RHEL guests takes too long (more than 50 minutes) in some scenarios
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Kevin Wolf
QA Contact: Yanhui Ma
URL:
Whiteboard:
: 1220306 1265894 (view as bug list)
Depends On:
Blocks: 1265894 1291175
TreeView+ depends on / blocked
 
Reported: 2014-01-20 02:23 UTC by xhan
Modified: 2018-12-13 20:55 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-13 20:55:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description xhan 2014-01-20 02:23:40 UTC
Description of problem:

Intall RHEL7.0 guest in drive_cache=none takes more than 50 minutes.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-36.el7.x86_64
kernel-3.10.0-69.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install rhel7 guest automatically
/home/autotest/autotest-devel/client/tests/virt/qemu/qemu \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -M pc  \
    -nodefaults  \
    -vga cirrus  \
    -monitor stdio \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
    -device ahci,id=ahci0,bus=pci.0,addr=04 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,file=RHEL-Server-7.0-64.raw \
    -device ide-hd,id=image1,drive=drive_image1,bus=ahci0.0,unit=0 \
    -device e1000,mac=9a:f2:f3:f4:f5:f6,id=idcw8aq6,netdev=idYYk2kX,bus=pci.0,addr=05  \
    -netdev tap,id=idYYk2kX,script=/etc/qemu-ifup \
    -m 1048  \
    -smp 1,maxcpus=1,cores=1,threads=1,sockets=2  \
    -cpu 'Opteron_G2',+kvm_pv_unhalt \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=RHEL7.0-Server-x86_64.iso \
    -device ide-cd,id=cd1,drive=drive_cd1,bus=ahci0.1,unit=0 \
    -drive id=drive_fl,if=none,cache=none,snapshot=off,readonly=off,aio=native,file=images/rhel70-64/ks.vfd \
    -global isa-fdc.driveA=drive_fl \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -kernel 'data/images/rhel70-64/vmlinuz'  \
    -append 'ks=hd:fd0:/ks.cfg nicdelay=60 console=ttyS0,115200 console=tty0'  \
    -initrd 'data/images/rhel70-64/initrd.img'  \
    -vnc :0  \
    -rtc base=utc,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off  \
    -no-kvm-pit-reinjection \
    -no-shutdown \
    -enable-kvm

2. wait for guest finishes
3.

Actual results:
The installation progress would take more than 50 minutes. This is longer than the installation with drive_cache=unsafe which only takes around 25 minutes.


Expected results:
The performace of the installation with drive_cache=none would not be slower than with drive_cache=unsafe too much.
 

Additional info:

[root@amd-5600-4-1 qemu]# cat /proc/cpuinfo 
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
stepping	: 2
cpu MHz		: 2900.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good nopl extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv
bogomips	: 5812.61
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

Comment 2 juzhang 2014-01-20 02:59:44 UTC
Hi Xhan,

It is a regression? Do you have the older data?

Best Regards,
Junyi

Comment 3 xhan 2014-01-20 07:16:36 UTC
1)Test installation on real machine with the same profile. The installation would take around 16 minutes.

2) Tried on qemu-kvm-1.5.3-20.el7, there is still this defect. 

3) Would try this test again with -smp 2,maxcpus=2,cores=1,threads=1,sockets=2, if the reserved machined is ready. And would paste the result here.

Comment 4 xhan 2014-01-22 08:58:48 UTC
paste the result here 
3) Would try this test again with -smp 2,maxcpus=2,cores=1,threads=1,sockets=2,

The installation process also need more than 50 minutes to finish.

Test the results on the same host: 5600-4-1

Comment 5 Kevin Wolf 2014-01-31 11:20:29 UTC
I see that you are using AHCI for this test installation. Can you please try
for comparison how long it takes with virtio-blk and/or virtio-scsi?

Comment 6 xhan 2014-02-08 01:45:29 UTC
Test with virtio-blk and virtio-scsi, and the results are the same. They need take more than 50 minutes to finish.

Comment 7 Kevin Wolf 2014-02-14 11:21:54 UTC
How long does it take on a RHEL 6 host? That is, do we have a regression or is
this the usual behaviour?

FWIW, when I installed a RHEL 7 VM, it didn't appear to be unusually slow, though
I haven't measured it. Perhaps it's also related to the specific machine you're
using.

Comment 8 juzhang 2014-02-17 02:00:37 UTC
(In reply to Kevin Wolf from comment #7)
> How long does it take on a RHEL 6 host? That is, do we have a regression or
> is
> this the usual behaviour?
> 
> FWIW, when I installed a RHEL 7 VM, it didn't appear to be unusually slow,
> though
> I haven't measured it. Perhaps it's also related to the specific machine
> you're
> using.

Hi Xhan,

Could you have a look comment7 and add your comment?

Best Regards,
Junyi

Comment 9 xhan 2014-02-18 03:14:01 UTC
Select two machine to test this case. One is amd-5600-4-1, the other one is intel-e31225-8-3. 

The result:

Host                                  Install Duration

RHEL6 (	intel-e31225-8-3)                22 mins
RHEL7 (	intel-e31225-8-3)                41 mins
  qemu-kvm-1.5.3-47.el7.x86_64

RHEL6 ( amd-5600-4-1)                    36 mins
  qemu-kvm-rhev-0.12.1.2-2.420.el6.x86_64

RHEL6 ( amd-5600-4-1)                    36 mins
  qemu-kvm-1.5.3-47.el7.x86_64           >50 mins

Yes, this problem happens on the specific machine.

Comment 10 xhan 2014-02-18 03:21:26 UTC
(In reply to xhan from comment #9)
> Select two machine to test this case. One is amd-5600-4-1, the other one is
> intel-e31225-8-3. 
> 
> The result:
> 
> Host                                  Install Duration
> 
> RHEL6 (	intel-e31225-8-3)                22 mins
> RHEL7 (	intel-e31225-8-3)                41 mins
>   qemu-kvm-1.5.3-47.el7.x86_64
> 
> RHEL6 ( amd-5600-4-1)                    36 mins
>   qemu-kvm-rhev-0.12.1.2-2.420.el6.x86_64
> 
> RHEL7 ( amd-5600-4-1)                    
Correct the typo line
>   qemu-kvm-1.5.3-47.el7.x86_64           >50 mins
> 
> Yes, this problem happens on the specific machine.

Comment 11 xu 2014-03-25 11:11:00 UTC
Hi Kevin

any comment about this performance issue ?

Thanks,
Xu

Comment 17 Ademar Reis 2017-05-12 13:20:22 UTC
The component is set to qemu-kvm, but the description talks about qemu-kvm-rhev and later qemu-kvm.

Please confirm if this bug is still valid and clarify if component should be qemu-kvm-rhev or only qemu-kvm.

(postponing it to RHEL-7.5 in the meanwhile, so consider it low priority)

Comment 18 Ademar Reis 2017-05-12 13:22:34 UTC
Probably related to Bug 1220306. Are the two tests are being run on the same machine?

Comment 19 Ademar Reis 2017-05-12 13:29:25 UTC
There are two other BZs with a similar use-case. I'm merging them all into this one:

Bug 1220306 and Bug 1265894.

Comment 20 Ademar Reis 2017-05-12 13:30:06 UTC
*** Bug 1220306 has been marked as a duplicate of this bug. ***

Comment 21 Ademar Reis 2017-05-12 13:33:38 UTC
*** Bug 1265894 has been marked as a duplicate of this bug. ***

Comment 22 Yanhui Ma 2017-05-23 01:56:45 UTC
I will investigate these related bz later, now I am busy on rhel7.4 test and no idle hosts also.


Note You need to log in before you can comment on or make changes to this bug.