Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055318 - CSS errors in Bugzilla
Summary: CSS errors in Bugzilla
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: 4.4
Assignee: Matt Tyson 🤬
QA Contact: Simon Green
URL:
Whiteboard:
Depends On:
Blocks: 1115362
TreeView+ depends on / blocked
 
Reported: 2014-01-20 00:36 UTC by Jason McDonald
Modified: 2018-12-09 06:29 UTC (History)
4 users (show)

Fixed In Version: 4.4.2014
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1115362 (view as bug list)
Environment:
Last Closed: 2014-03-03 01:00:24 UTC


Attachments (Terms of Use)

Description Jason McDonald 2014-01-20 00:36:57 UTC
Description of problem:
When using the Firefox console, one can see a variety of minor css errors when loading page from RH Bugzilla.

For example, see the following logs for the home page and the "My Bugs" page.

10:25:36.812 GET https://bugzilla.redhat.com/ [HTTP/1.1 200 OK 3417ms]
10:25:40.230 Error in parsing value for 'white-space'.  Declaration dropped. global.css:291
10:25:40.230 Error in parsing value for 'white-space'.  Declaration dropped. global.css:292
10:25:40.230 Error in parsing value for 'white-space'.  Declaration dropped. global.css:293
10:25:40.231 Unknown property '-moz-border-radius-topleft'.  Declaration dropped. global.css:15
10:25:40.231 Unknown property '-moz-border-radius-topright'.  Declaration dropped. global.css:16
10:25:40.232 Unknown property '-moz-border-radius-bottomleft'.  Declaration dropped. global.css:24
10:25:40.232 Unknown property '-moz-border-radius-bottomright'.  Declaration dropped. global.css:25
10:25:40.232 Unknown property '-moz-border-radius'.  Declaration dropped. global.css:48
10:25:40.232 Unknown property '-moz-border-radius'.  Declaration dropped. global.css:195
10:25:40.232 Unknown property '-moz-border-radius'.  Declaration dropped. index.css:21


10:26:47.150 GET https://bugzilla.redhat.com/buglist.cgi [HTTP/1.1 302 Found 2301ms]
10:26:49.530 GET http://bugzilla.redhat.com/buglist.cgi [Mixed Content][HTTP/1.0 302 Found 2208ms]
10:26:51.668 GET https://bugzilla.redhat.com/buglist.cgi [HTTP/1.1 200 OK 24844ms]
10:27:13.520 Unknown property '-moz-opacity'.  Declaration dropped. autocomplete.css:7
10:27:13.520 Expected 'none' or URL but found 'alpha('.  Error in parsing value for 'filter'.  Declaration dropped. autocomplete.css:7
10:27:13.520 Unknown property 'zoom'.  Declaration dropped. autocomplete.css:7
10:27:13.521 Expected declaration but found '*'.  Skipped to next declaration. calendar.css:7
10:27:13.521 Unknown property 'zoom'.  Declaration dropped. calendar.css:7
10:27:13.521 Expected 'none' or URL but found 'alpha('.  Error in parsing value for 'filter'.  Declaration dropped. calendar.css:7
10:27:13.521 Expected declaration but found '*'.  Skipped to next declaration. calendar.css:8
10:27:13.523 Error in parsing value for 'white-space'.  Declaration dropped. global.css:291
10:27:13.523 Error in parsing value for 'white-space'.  Declaration dropped. global.css:292
10:27:13.523 Error in parsing value for 'white-space'.  Declaration dropped. global.css:293
10:27:13.525 Unknown property '-moz-border-radius-topleft'.  Declaration dropped. global.css:15
10:27:13.525 Unknown property '-moz-border-radius-topright'.  Declaration dropped. global.css:16
10:27:13.525 Unknown property '-moz-border-radius-bottomleft'.  Declaration dropped. global.css:24
10:27:13.525 Unknown property '-moz-border-radius-bottomright'.  Declaration dropped. global.css:25
10:27:13.525 Unknown property '-moz-border-radius'.  Declaration dropped. global.css:48
10:27:13.526 Unknown property '-moz-border-radius'.  Declaration dropped. global.css:195


Version-Release number of selected component (if applicable):
4.4.1012-2  (tested on Fedora 20 and Firefox 26.0)

How reproducible:
Always

Steps to Reproduce:
1. Open the firefox console (press Shift+F2 then click the spanner icon on the right-hand end of the bar that appears at the bottomof the browser window).
2. Click "clear" to delete any previous output from the console
3. Load https://bugzilla.redhat.com/ 

Actual results:
Console shows css errors.

Expected results:
Console shows no errors.

Additional info:
none.

Comment 1 Matt Tyson 🤬 2014-02-03 01:02:07 UTC
A lot of these were caused by obsolete vendor specific CSS tags used in Red Hat css code.
I've replaced the CSS tags with the standard css3 versions.


A number of these other errors come from the YUI2 library which was closed for development in 2011.  I haven't attempted to fix these.

Comment 2 Matt Tyson 🤬 2014-03-03 01:00:24 UTC
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.