Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055230 - spring and spring lobby versions are outdated
Summary: spring and spring lobby versions are outdated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spring
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gilboa Davara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1055231 1075248 1089491 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-19 17:39 UTC by Benjamin Bellec
Modified: 2014-05-06 03:38 UTC (History)
4 users (show)

Fixed In Version: spring-96.0-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-06 03:28:52 UTC


Attachments (Terms of Use)

Description Benjamin Bellec 2014-01-19 17:39:29 UTC
Description of problem:
Spring 0.96 is out since January 03 and is required to play online.

Version-Release number of selected component (if applicable):
Currently in Fedora repo is spring 0.95

Comment 1 Gilboa Davara 2014-01-28 18:29:58 UTC
Known issue.
http://springrts.com/phpbb/viewtopic.php?f=20&t=31393&p=553306#p553306

- Gilboa

Comment 2 Gilboa Davara 2014-03-17 10:44:09 UTC
Hello all,

Spring 96 requires a lot of effort due to a large number of issues that revolve around prdownloder library (DSO errors, springlobby issues, etc).

I'm currently working with upstream to to get 96 building and running.

Hopefully the last bug / patch / etc will be issued later this week so I can get spring 96 w/ springlobby 180 out.

- Gilboa

Comment 3 Gilboa Davara 2014-03-17 10:44:39 UTC
*** Bug 1055231 has been marked as a duplicate of this bug. ***

Comment 4 Gilboa Davara 2014-03-17 10:44:42 UTC
*** Bug 1075248 has been marked as a duplicate of this bug. ***

Comment 5 MERCIER Jonathan 2014-03-20 01:20:25 UTC
yeah thanks for your works

Comment 6 MERCIER Jonathan 2014-04-04 15:08:50 UTC
Hi Gilboa Davara,

did you have got some news ?

anyway good luck :-)

Comment 7 Gilboa Davara 2014-04-05 08:42:48 UTC
To be honest, I'm about to give up; the pr-downloader library while patched to the teeth, simply refuses to build reliably under the Fedora build system.
I'm inches from detaching it from the spring build system and creating an alternate build environment just to get it working. (pr-downloader is required by the latest releases of springlobby).

- Gilboa

Comment 8 Gilboa Davara 2014-04-05 09:03:17 UTC
The threat worked :)
I managed to make some headway. Still working on it.

- Gilboa

Comment 9 Gilboa Davara 2014-04-19 18:08:23 UTC
*** Bug 1089491 has been marked as a duplicate of this bug. ***

Comment 10 Gilboa Davara 2014-04-19 18:10:10 UTC
Short update.
Got spring 96 reliably working on Fedora 20, however, even a (heavily) patched version of 96 breaks springlobby download.
I'm currently working with spring devs to resolve this issue.

- Gilboa

Comment 11 Fedora Update System 2014-04-23 05:36:29 UTC
spring-96.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/spring-96.0-2.fc19

Comment 12 Fedora Update System 2014-04-23 05:36:45 UTC
spring-96.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/spring-96.0-2.fc20

Comment 13 Gilboa Davara 2014-04-23 05:42:49 UTC
I managed to get spring working, while keeping the current springlobby.
Please test the above links.

Once pr-downloader stabilizes I'll issue a new spring (hopefully by then 97 will be released) and new springlobby builds.

- Gilboa

Comment 14 Fedora Update System 2014-04-24 07:41:52 UTC
Package spring-96.0-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spring-96.0-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5542/spring-96.0-2.fc19
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2014-05-06 03:28:52 UTC
spring-96.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2014-05-06 03:38:43 UTC
spring-96.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.