Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055214 - SELinux is preventing /usr/bin/Xorg from using the 'setuid' capabilities.
Summary: SELinux is preventing /usr/bin/Xorg from using the 'setuid' capabilities.
Keywords:
Status: CLOSED DUPLICATE of bug 1055211
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9394d7b3b5de6476b576b005c6e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-19 15:45 UTC by Zero
Modified: 2014-01-19 18:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-19 18:25:10 UTC


Attachments (Terms of Use)

Description Zero 2014-01-19 15:45:44 UTC
Description of problem:
SELinux is preventing /usr/bin/Xorg from using the 'setuid' capabilities.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that Xorg should have the setuid capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep Xorg /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:bumblebee_t:s0
Target Context                system_u:system_r:bumblebee_t:s0
Target Objects                 [ capability ]
Source                        Xorg
Source Path                   /usr/bin/Xorg
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-server-Xorg-1.14.4-5.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-106.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.12.7-300.fc20.x86_64 #1 SMP Fri
                              Jan 10 15:35:31 UTC 2014 x86_64 x86_64
Alert Count                   10
First Seen                    2014-01-14 13:27:13 CET
Last Seen                     2014-01-16 14:31:45 CET
Local ID                      37ca8809-4460-4d4e-b383-fa106915c715

Raw Audit Messages
type=AVC msg=audit(1389879105.537:443): avc:  denied  { setuid } for  pid=3141 comm="Xorg" capability=7  scontext=system_u:system_r:bumblebee_t:s0 tcontext=system_u:system_r:bumblebee_t:s0 tclass=capability


type=SYSCALL msg=audit(1389879105.537:443): arch=x86_64 syscall=setuid success=yes exit=0 a0=0 a1=5b510d a2=1fd5cb0 a3=30dd21c310 items=0 ppid=2664 pid=3141 auid=4294967295 uid=0 gid=1001 euid=0 suid=0 fsuid=0 egid=1001 sgid=1001 fsgid=1001 ses=4294967295 tty=(none) comm=Xorg exe=/usr/bin/Xorg subj=system_u:system_r:bumblebee_t:s0 key=(null)

Hash: Xorg,bumblebee_t,bumblebee_t,capability,setuid

Additional info:
reporter:       libreport-2.1.11
hashmarkername: setroubleshoot
kernel:         3.12.7-300.fc20.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-01-19 18:25:10 UTC

*** This bug has been marked as a duplicate of bug 1055211 ***


Note You need to log in before you can comment on or make changes to this bug.