Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055172 - SELinux is preventing /usr/bin/qemu-system-x86_64 from 'read' accesses on the blk_file /dev/dm-6.
Summary: SELinux is preventing /usr/bin/qemu-system-x86_64 from 'read' accesses on the...
Keywords:
Status: CLOSED DUPLICATE of bug 1055168
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1428ad7134e58003fe1f0817714...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-19 11:50 UTC by Mateusz Marzantowicz
Modified: 2014-01-19 19:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-19 19:56:02 UTC


Attachments (Terms of Use)

Description Mateusz Marzantowicz 2014-01-19 11:50:40 UTC
Description of problem:
It happened after updating selinux-policy-targeted  to selinux-policy-targeted-3.12.1-117.fc20.noarch.
SELinux is preventing /usr/bin/qemu-system-x86_64 from 'read' accesses on the blk_file /dev/dm-6.

*****  Plugin catchall (100. confidence) suggests   **************************

If aby qemu-system-x86_64 powinno mieć domyślnie read dostęp do dm-6 blk_file.
Then proszę to zgłosić jako błąd.
Można utworzyć lokalny moduł polityki, aby umożliwić ten dostęp.
Do
można tymczasowo zezwolić na ten dostęp wykonując polecenia:
# grep qemu:Mail /var/log/audit/audit.log | audit2allow -M mojapolityka
# semodule -i mojapolityka.pp

Additional Information:
Source Context                system_u:system_r:svirt_t:s0:c9,c556
Target Context                system_u:object_r:fixed_disk_device_t:s0
Target Objects                /dev/dm-6 [ blk_file ]
Source                        qemu:Mail
Source Path                   /usr/bin/qemu-system-x86_64
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           qemu-system-x86-1.6.1-3.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-117.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.12.7-300.fc20.x86_64 #1 SMP Fri
                              Jan 10 15:35:31 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-01-19 12:38:57 CET
Last Seen                     2014-01-19 12:38:57 CET
Local ID                      492be064-9b05-4a04-91f3-8b6cd31757be

Raw Audit Messages
type=AVC msg=audit(1390131537.190:2492): avc:  denied  { read } for  pid=23609 comm="qemu:Mail" path="/dev/dm-6" dev="devtmpfs" ino=14704 scontext=system_u:system_r:svirt_t:s0:c9,c556 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file


type=SYSCALL msg=audit(1390131537.190:2492): arch=x86_64 syscall=preadv success=yes exit=12288 a0=10 a1=7f9363e9b768 a2=3 a3=18924a000 items=0 ppid=1 pid=23609 auid=4294967295 uid=107 gid=107 euid=107 suid=107 fsuid=107 egid=107 sgid=107 fsgid=107 ses=4294967295 tty=(none) comm=qemu:Mail exe=/usr/bin/qemu-system-x86_64 subj=system_u:system_r:svirt_t:s0:c9,c556 key=(null)

Hash: qemu:Mail,svirt_t,fixed_disk_device_t,blk_file,read

Additional info:
reporter:       libreport-2.1.11
hashmarkername: setroubleshoot
kernel:         3.12.7-300.fc20.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-01-19 19:56:02 UTC

*** This bug has been marked as a duplicate of bug 1055168 ***


Note You need to log in before you can comment on or make changes to this bug.