Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055161 - [engine][network] Missing audit log for mass operations
Summary: [engine][network] Missing audit log for mass operations
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.4.0
Assignee: Mike Kolesnik
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-19 09:54 UTC by Mike Kolesnik
Modified: 2014-04-01 05:01 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:30:08 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24357 None None None Never
oVirt gerrit 24358 None None None Never

Description Mike Kolesnik 2014-01-19 09:54:09 UTC
Description of problem:
Mass network operations should be logged per 
http://www.ovirt.org/Features/MultiHostNetworkConfiguration#Events

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Perform "update network command"
2.
3.

Actual results:
No audit logs are written


Expected results:
Audit logs should be written per http://www.ovirt.org/Features/MultiHostNetworkConfiguration#Events


Additional info:

Comment 1 Sandro Bonazzola 2014-02-19 12:26:58 UTC
This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

Comment 2 Martin Pavlik 2014-02-27 14:36:42 UTC
works with oVirt Engine Version: 3.4.0-0.11.beta3.el6 

(1/1): Successfully applied changes for network(s) NET2 on host dell-08. (User: admin)
Network NET2 attached to Cluster Default
(1/1): Applying changes for network(s) NET2 on host dell-08. (User: admin)	
Network NET2 cannot be configured using the label lb_2 in data-center Default on the following hosts: 10.34.66.61.

Error while executing action: Cannot edit Network. Several virtual machines (1) are using this logical network:
F20-0
- Please remove it from all virtual machines that are using it and try again.

Comment 3 Sandro Bonazzola 2014-03-31 12:30:08 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.