Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055157 - Use linux16/initrd16 in grub.cfg for BIOS boot
Summary: Use linux16/initrd16 in grub.cfg for BIOS boot
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-19 09:18 UTC by Jochen Schmitt
Modified: 2014-01-20 17:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-20 17:31:06 UTC


Attachments (Terms of Use)

Description Jochen Schmitt 2014-01-19 09:18:20 UTC
On my MBP late 2014 I get a blank screen when I try to boot Fedora 20 in BIOS mode.

After a test drive of RHEL 7 Beta I have found, that this issue doesn't occures if you replace the linux and initrd commands in the grub.cfg file by linux16 and initrd16.

So I want to suggest, that the file /etc/grub.d/10_linux should change in a way, that a grub.cfg file created for BIOS based booting should contains the linux16 and initrd16 commands instead of linux and initrd.

Comment 1 Mads Kiilerich 2014-01-19 09:35:39 UTC
linux16 and initrd16 instead of what? linuxefi and initrdefi?

Comment 2 Jochen Schmitt 2014-01-19 10:18:43 UTC
No, If you install Fedora on a Mac a special BIOS Boot partition will been created which allows you to boot your system in BIOS mode.
I suggest to use 'linux16' and 'initrd16' instead of 'linux' and 'initrd' to boot in BIOS mode, because
I have an issue on booting the system in BIOS mode.
This issue did't occures if you are booting your system in EFI mode.

Comment 3 Mads Kiilerich 2014-01-19 10:28:12 UTC
You should install and use efi mode. BIOS might in some cases work and have some advantages but is not supportable and not supported. If anything, the root cause for why you "need" this workaround should be found and fixed.

Comment 4 Jochen Schmitt 2014-01-19 11:38:45 UTC
OK, it may be nice, if you can anser the folowing questions:

1.) Why doens RHEL 7 use linux16 for i?86 and x86_64 systems?

2.) Why does Fedora make a BIOS based install on a EFI system?

Best Regards:

Jochen Schmitt

Comment 5 Mads Kiilerich 2014-01-19 12:01:40 UTC
(In reply to Jochen Schmitt from comment #4)
> 2.) Why does Fedora make a BIOS based install on a EFI system?

Probably because you booted the install media as BIOS, leaving Fedora with no access to the EFI firmware.

Comment 6 Brian Lane 2014-01-20 17:31:06 UTC
I am not sure how you booted in CSM mode, but F20 works just fine on Mac hardware if you boot and install by holding down option and selecting the fedora logo. Boot media should be created by using dd to write the iso to a USB stick.


Note You need to log in before you can comment on or make changes to this bug.