Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055156 - warning: %postun(ovirt-scheduler-proxy-0.1.3-3.el6ev.noarch) scriptlet failed
Summary: warning: %postun(ovirt-scheduler-proxy-0.1.3-3.el6ev.noarch) scriptlet failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-scheduler-proxy
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.3.0
Assignee: Martin Sivák
QA Contact: Pavel Stehlik
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-19 09:16 UTC by Pavel Stehlik
Modified: 2016-02-10 20:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When uninstalling the ovirt-scheduler-proxy from a System V init based system, chkconfig was called after the main init file was already deleted, resulting in postun script failure. This update adds a preun script to stop the service before the init file is deleted, and also adds a systemd preun management macro. Now uninstalling ovirt-scheduler-proxy succeeds without error.
Clone Of:
Environment:
Last Closed: 2014-01-22 16:20:39 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0088 normal SHIPPED_LIVE ovirt-scheduler-proxy bug fix and enhancement update 2014-01-22 21:19:50 UTC
oVirt gerrit 23411 None None None Never

Comment 1 Martin Sivák 2014-01-19 15:57:11 UTC
It seems to be caused by the following line in the spec file's %postun:

chkconfig --del ovirt-scheduler-proxy

Post uninstall might not be a good place for it.. if the init file is managed by rpm, it was probably deleted already.


Pavel, can you check if there are symlinks to the (probably missing) init file even after the removal in /etc/rc.*?

If there are, we will have to change the section to %preun and try again. That will require a package rebuild, but no source code change (spec only).

Comment 4 errata-xmlrpc 2014-01-22 16:20:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0088.html


Note You need to log in before you can comment on or make changes to this bug.