Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055129 - service vdsmd start fails after vdsm-tool configure --force
Summary: service vdsmd start fails after vdsm-tool configure --force
Keywords:
Status: CLOSED DUPLICATE of bug 1055153
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.4.0
Assignee: Douglas Schilling Landgraf
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-19 01:10 UTC by Andrew Lau
Modified: 2014-09-28 06:36 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-27 02:08:38 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Andrew Lau 2014-01-19 01:10:16 UTC
Description of problem:
The ovirt-hosted-engine-setup will always fail on first run because of the `vdsm-tool configure`. I've run this a few times on my centos box, and every "new install" the first run has always failed with this error in the logs:


2014-01-19 12:01:26 DEBUG otopi.plugins.otopi.services.rhel plugin.execute:446 execute-output: ('/sbin/initctl', 'status', 'vdsmd') stderr:
initctl: Unknown job: vdsmd

2014-01-19 12:01:26 DEBUG otopi.plugins.otopi.services.rhel plugin.executeRaw:366 execute: ('/sbin/service', 'vdsmd', 'start'), executable='None', cwd='None', env=None
2014-01-19 12:01:30 DEBUG otopi.plugins.otopi.services.rhel plugin.executeRaw:383 execute-result: ('/sbin/service', 'vdsmd', 'start'), rc=1
2014-01-19 12:01:30 DEBUG otopi.plugins.otopi.services.rhel plugin.execute:441 execute-output: ('/sbin/service', 'vdsmd', 'start') stdout:
Starting multipathd daemon: [  OK  ]
Starting rpcbind: [  OK  ]
Starting ntpd: [  OK  ]
Starting wdmd: [  OK  ]
Starting sanlock: [  OK  ]
supervdsm start[  OK  ]
vdsm: Running mkdirs
vdsm: Running configure_coredump
vdsm: Running run_init_hooks
vdsm: Running gencerts
Configuring a self-signed VDSM host certificatevdsm: Running check_is_configured
libvirt is already configured for vdsm
sanlock service requires restart
Modules sanlock are not configured
 vdsm: failed to execute check_is_configured, error code 1
vdsm start[FAILED]

2014-01-19 12:01:30 DEBUG otopi.plugins.otopi.services.rhel plugin.execute:446 execute-output: ('/sbin/service', 'vdsmd', 'start') stderr:
initctl: Job is already running: libvirtd
Traceback (most recent call last):
  File "/usr/bin/vdsm-tool", line 145, in <module>
    sys.exit(main())
  File "/usr/bin/vdsm-tool", line 142, in main
    return tool_command[cmd]["command"](*args[1:])
  File "/usr/lib64/python2.6/site-packages/vdsm/tool/configurator.py", line 243, in isconfigured
    raise RuntimeError("Not configured. Try 'vdsm-tool configure'")
RuntimeError: Not configured. Try 'vdsm-tool configure'

2014-01-19 12:01:30 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/system/vdsmenv.py", line 154, in _late_setup
    state=True
  File "/usr/share/otopi/plugins/otopi/services/rhel.py", line 188, in state
    'start' if state else 'stop'
  File "/usr/share/otopi/plugins/otopi/services/rhel.py", line 96, in _executeServiceCommand
    raiseOnError=raiseOnError
  File "/usr/lib/python2.6/site-packages/otopi/plugin.py", line 451, in execute
    command=args[0],
RuntimeError: Command '/sbin/service' failed to execute
2014-01-19 12:01:30 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Environment setup': Command '/sbin/service' failed to execute


Full Version here: http://www.fpaste.org/69717/39009358/

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.2.0-0.0.master.20140117.gitfaf77a5.el6.noarch
ovirt-hosted-engine-ha-1.1.0-0.0.master.20140116.git3db8f76.el6.noarch
vdsm-4.14.0-29.git6c6da59.el6.x86_6

How reproducible:
All three times which I've tried.

Steps to Reproduce:
1. Install new CentOS box and install ovirt alpha repo
2. Run `ovirt-hosted-engine-setup` and it will error
3. Re-run the setup

Actual results:
First run always errors

Expected results:
First run should work

Additional info:

Comment 1 Sandro Bonazzola 2014-01-20 08:32:04 UTC
From the logs in  http://www.fpaste.org/69717/39009358/


2014-01-19 12:01:25 DEBUG otopi.plugins.ovirt_hosted_engine_setup.system.vdsmenv plugin.executeRaw:366 execute: ('/usr/bin/vdsm-tool', 'configure', '--force'), executable='None', cwd='None', env=None
2014-01-19 12:01:26 DEBUG otopi.plugins.ovirt_hosted_engine_setup.system.vdsmenv plugin.executeRaw:383 execute-result: ('/usr/bin/vdsm-tool', 'configure', '--force'), rc=0
2014-01-19 12:01:26 DEBUG otopi.plugins.ovirt_hosted_engine_setup.system.vdsmenv plugin.execute:441 execute-output: ('/usr/bin/vdsm-tool', 'configure', '--force') stdout:
SUCCESS: ssl configured to true. No conflicts
sanlock service is not running
sanlock service is already configured
Reconfiguration of libvirt is done.
 
2014-01-19 12:01:26 DEBUG otopi.plugins.ovirt_hosted_engine_setup.system.vdsmenv plugin.execute:446 execute-output: ('/usr/bin/vdsm-tool', 'configure', '--force') stderr:
service-status: ServiceOperationError: _serviceStatus failed
Super VDSM daemon is not running
 
service-status: ServiceOperationError: _serviceStatus failed
VDS daemon is not running
 
service-status: ServiceOperationError: _serviceStatus failed
libvirtd is stopped

so hosted-engine --deploy first run "vdsm-tool configure --force"
but then:

2014-01-19 12:01:30 DEBUG otopi.plugins.otopi.services.rhel plugin.execute:446 execute-output: ('/sbin/service', 'vdsmd', 'start') stderr:
initctl: Job is already running: libvirtd
Traceback (most recent call last):
  File "/usr/bin/vdsm-tool", line 145, in <module>
    sys.exit(main())
  File "/usr/bin/vdsm-tool", line 142, in main
    return tool_command[cmd]["command"](*args[1:])
  File "/usr/lib64/python2.6/site-packages/vdsm/tool/configurator.py", line 243, in isconfigured
    raise RuntimeError("Not configured. Try 'vdsm-tool configure'")
RuntimeError: Not configured. Try 'vdsm-tool configure'

Moving the bug to vdsm-tool.

Comment 2 Sandro Bonazzola 2014-01-24 14:41:23 UTC
Dan maybe this is somewhat related to the other bug about vdsm.log ownership.

Comment 3 Dan Kenigsberg 2014-01-27 01:18:17 UTC
Yes, this seems like a dup of bug 1055153. Andrew, would you confirm?

Comment 4 Andrew Lau 2014-01-27 02:08:38 UTC
Now that the issue was isolated to vdsm, it really looks like it is. I'll mark it as a duplicate as both the BZs were opened by me anyway.

*** This bug has been marked as a duplicate of bug 1055153 ***


Note You need to log in before you can comment on or make changes to this bug.