Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055091 - copr-cli list ssl errors
Summary: copr-cli list ssl errors
Keywords:
Status: CLOSED DUPLICATE of bug 1054594
Alias: None
Product: Fedora
Classification: Fedora
Component: copr
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-18 18:54 UTC by John Ellson
Modified: 2014-01-20 08:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-20 08:12:00 UTC


Attachments (Terms of Use)

Description John Ellson 2014-01-18 18:54:06 UTC
Description of problem:
New copr user  "ellson", trying to get started ...   
get as far as trying "copr-cli list"

Version-Release number of selected component (if applicable):
copr-cli-1.21-1.fc20.noarch

How reproducible:
100%

Steps to Reproduce:
1.cut&paste API token from http://copr.fedoraproject.org/api/ to ~/.config/copr
2.copr-cli list
3.

Actual results:
Traceback (most recent call last):
  File "/bin/copr-cli", line 9, in <module>
    load_entry_point('copr-cli==0.2.0', 'console_scripts', 'copr-cli')()
  File "/usr/lib/python2.7/site-packages/copr_cli/main.py", line 126, in main
    arg.func(arg)
  File "/usr/lib/python2.7/site-packages/copr_cli/main.py", line 44, in action_list
    subcommands.listcoprs(args.username)
  File "/usr/lib/python2.7/site-packages/copr_cli/subcommands.py", line 91, in listcoprs
    req = requests.get(url)
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 55, in get
    return request('get', url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 44, in request
    return session.request(method=method, url=url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 335, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 438, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/adapters.py", line 331, in send
    raise SSLError(e)
requests.exceptions.SSLError: [Errno 1] _ssl.c:504: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

Expected results:
a list of my copr's  -- expected to be an empty list at this time

Additional info:

Comment 1 Miroslav Suchý 2014-01-20 08:12:00 UTC
Please edit your ~/.config/copr and replace https with http.

*** This bug has been marked as a duplicate of bug 1054594 ***


Note You need to log in before you can comment on or make changes to this bug.