Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055075 - yum-3.4.3-129.fc20 "scriptlet failed, exit status 127"
Summary: yum-3.4.3-129.fc20 "scriptlet failed, exit status 127"
Keywords:
Status: CLOSED DUPLICATE of bug 1054350
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-18 15:55 UTC by Davide Repetto
Modified: 2014-01-18 18:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-18 18:44:34 UTC


Attachments (Terms of Use)

Description Davide Repetto 2014-01-18 15:55:02 UTC
Description of problem:
=======================
yum-3.4.3-129.fc20 gives a lot of "scriptlet failed, exit status 127" in prein and postin scriptles. Many packages fail to install and uninstall properly.

Things go back to normal "setenforce 0" but in the logs I can find no avc denials to justify this behaviours.

Version-Release number of selected component (if applicable):
=============================================================
yum-3.4.3-129.fc20.noarch
selinux-policy-targeted-3.12.1-116.fc20.noarch
selinux-policy-3.12.1-116.fc20.noarch

How reproducible:
=================
Install, upgrade or remove a few tens of packages.

Actual results: / Additional info:
==================================
Downloading packages:
(1/12): file-5.14-14.fc20.x86_64.rpm                                                                          |  56 kB  00:00:00     
(2/12): file-libs-5.14-14.fc20.x86_64.rpm                                                                     | 367 kB  00:00:00     
(3/12): firefox-26.0-5.fc20.x86_64.rpm                                                                        |  49 MB  00:00:04     
(4/12): gnome-abrt-0.3.5-1.fc20.x86_64.rpm                                                                    | 200 kB  00:00:00     
(5/12): ibus-1.5.5-1.fc20.x86_64.rpm                                                                          | 356 kB  00:00:00     
(6/12): ibus-gtk2-1.5.5-1.fc20.x86_64.rpm                                                                     |  42 kB  00:00:00     
(7/12): ibus-gtk3-1.5.5-1.fc20.x86_64.rpm                                                                     |  42 kB  00:00:00     
(8/12): ibus-libs-1.5.5-1.fc20.x86_64.rpm                                                                     | 207 kB  00:00:00     
(9/12): ibus-setup-1.5.5-1.fc20.noarch.rpm                                                                    |  66 kB  00:00:00     
(10/12): ibus-wayland-1.5.5-1.fc20.x86_64.rpm                                                                 |  38 kB  00:00:00     
(11/12): libpcap-1.5.3-1.fc20.x86_64.rpm                                                                      | 135 kB  00:00:00     
(12/12): nfs-utils-1.2.9-2.1.fc20.x86_64.rpm                                                                  | 356 kB  00:00:00     
-------------------------------------------------------------------------------------------------------------------------------------
Totale                                                                                               9.7 MB/s |  51 MB  00:00:05     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Attenzione: RPMDB modificato al di fuori di yum.
  Aggiornamento     : ibus-libs-1.5.5-1.fc20.x86_64                                                                             1/24 
warning: %post(ibus-libs-1.5.5-1.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package ibus-libs-1.5.5-1.fc20.x86_64
  Aggiornamento     : ibus-gtk2-1.5.5-1.fc20.x86_64                                                                             2/24 
warning: %post(ibus-gtk2-1.5.5-1.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package ibus-gtk2-1.5.5-1.fc20.x86_64
  Aggiornamento     : ibus-setup-1.5.5-1.fc20.noarch                                                                            3/24 
  Aggiornamento     : ibus-gtk3-1.5.5-1.fc20.x86_64                                                                             4/24 
warning: %post(ibus-gtk3-1.5.5-1.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package ibus-gtk3-1.5.5-1.fc20.x86_64
  Aggiornamento     : ibus-1.5.5-1.fc20.x86_64                                                                                  5/24 
warning: %post(ibus-1.5.5-1.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package ibus-1.5.5-1.fc20.x86_64
  Aggiornamento     : ibus-wayland-1.5.5-1.fc20.x86_64                                                                          6/24 
  Aggiornamento     : file-libs-5.14-14.fc20.x86_64                                                                             7/24 
warning: %post(file-libs-5.14-14.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package file-libs-5.14-14.fc20.x86_64
  Aggiornamento     : file-5.14-14.fc20.x86_64                                                                                  8/24 
  Aggiornamento     : gnome-abrt-0.3.5-1.fc20.x86_64                                                                            9/24 
warning: %post(gnome-abrt-0.3.5-1.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package gnome-abrt-0.3.5-1.fc20.x86_64
  Aggiornamento     : 14:libpcap-1.5.3-1.fc20.x86_64                                                                           10/24 
warning: %post(libpcap-14:1.5.3-1.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package 14:libpcap-1.5.3-1.fc20.x86_64
error: %pre(nfs-utils-1:1.2.9-2.1.fc20.x86_64) scriptlet failed, exit status 127
Error in PREIN scriptlet in rpm package 1:nfs-utils-1.2.9-2.1.fc20.x86_64
  Aggiornamento     : firefox-26.0-5.fc20.x86_64                                                                               12/24 
error: nfs-utils-1:1.2.9-2.1.fc20.x86_64: install failed
warning: %post(firefox-26.0-5.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package firefox-26.0-5.fc20.x86_64
  Pulizia           : ibus-gtk2-1.5.4-2.fc20.x86_64                                                                            13/24 
warning: %postun(ibus-gtk2-1.5.4-2.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTUN scriptlet failure in rpm package ibus-gtk2-1.5.4-2.fc20.x86_64
  Pulizia           : ibus-gtk3-1.5.4-2.fc20.x86_64                                                                            14/24 
warning: %postun(ibus-gtk3-1.5.4-2.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTUN scriptlet failure in rpm package ibus-gtk3-1.5.4-2.fc20.x86_64
  Pulizia           : ibus-setup-1.5.4-2.fc20.noarch                                                                           15/24 
  Pulizia           : ibus-1.5.4-2.fc20.x86_64                                                                                 16/24 
warning: %postun(ibus-1.5.4-2.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTUN scriptlet failure in rpm package ibus-1.5.4-2.fc20.x86_64
  Pulizia           : ibus-wayland-1.5.4-2.fc20.x86_64                                                                         17/24 
  Pulizia           : file-5.14-12.fc20.x86_64                                                                                 18/24 
  Pulizia           : file-libs-5.14-12.fc20.x86_64                                                                            19/24 
warning: %postun(file-libs-5.14-12.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTUN scriptlet failure in rpm package file-libs-5.14-12.fc20.x86_64
  Pulizia           : ibus-libs-1.5.4-2.fc20.x86_64                                                                            20/24 
warning: %postun(ibus-libs-1.5.4-2.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTUN scriptlet failure in rpm package ibus-libs-1.5.4-2.fc20.x86_64
  Pulizia           : gnome-abrt-0.3.4-1.fc20.x86_64                                                                           21/24 
warning: %postun(gnome-abrt-0.3.4-1.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTUN scriptlet failure in rpm package gnome-abrt-0.3.4-1.fc20.x86_64
  Pulizia           : 14:libpcap-1.5.0-1.20131108git459712e.fc20.x86_64                                                        22/24 
warning: %postun(libpcap-14:1.5.0-1.20131108git459712e.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTUN scriptlet failure in rpm package 14:libpcap-1.5.0-1.20131108git459712e.fc20.x86_64
error: nfs-utils-1:1.2.8-6.0.fc20.x86_64: erase skipped
error: %preun(firefox-26.0-3.fc20.x86_64) scriptlet failed, exit status 127
Error in PREUN scriptlet in rpm package firefox-26.0-3.fc20.x86_64
error: firefox-26.0-3.fc20.x86_64: erase failed
warning: %posttrans(ibus-1.5.5-1.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTTRANS scriptlet failure in rpm package ibus-1.5.5-1.fc20.x86_64
warning: %posttrans(gnome-abrt-0.3.5-1.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTTRANS scriptlet failure in rpm package gnome-abrt-0.3.5-1.fc20.x86_64
warning: %posttrans(firefox-26.0-5.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTTRANS scriptlet failure in rpm package firefox-26.0-5.fc20.x86_64
  Verifica in corso : file-libs-5.14-14.fc20.x86_64                                                                             1/24 
  Verifica in corso : firefox-26.0-5.fc20.x86_64                                                                                2/24 
  Verifica in corso : ibus-wayland-1.5.5-1.fc20.x86_64                                                                          3/24 
  Verifica in corso : ibus-gtk2-1.5.5-1.fc20.x86_64                                                                             4/24 
  Verifica in corso : ibus-setup-1.5.5-1.fc20.noarch                                                                            5/24 
  Verifica in corso : ibus-libs-1.5.5-1.fc20.x86_64                                                                             6/24 
  Verifica in corso : file-5.14-14.fc20.x86_64                                                                                  7/24 
  Verifica in corso : ibus-gtk3-1.5.5-1.fc20.x86_64                                                                             8/24 
  Verifica in corso : 14:libpcap-1.5.3-1.fc20.x86_64                                                                            9/24 
  Verifica in corso : gnome-abrt-0.3.5-1.fc20.x86_64                                                                           10/24 
  Verifica in corso : ibus-1.5.5-1.fc20.x86_64                                                                                 11/24 
  Verifica in corso : ibus-wayland-1.5.4-2.fc20.x86_64                                                                         12/24 
  Verifica in corso : firefox-26.0-3.fc20.x86_64                                                                               13/24 
  Verifica in corso : ibus-1.5.4-2.fc20.x86_64                                                                                 14/24 
1:nfs-utils-1.2.8-6.0.fc20.x86_64 was supposed to be removed but is not!
  Verifica in corso : 1:nfs-utils-1.2.8-6.0.fc20.x86_64                                                                        15/24 
  Verifica in corso : gnome-abrt-0.3.4-1.fc20.x86_64                                                                           16/24 
  Verifica in corso : 1:nfs-utils-1.2.9-2.1.fc20.x86_64                                                                        17/24 
  Verifica in corso : file-libs-5.14-12.fc20.x86_64                                                                            18/24 
  Verifica in corso : ibus-gtk2-1.5.4-2.fc20.x86_64                                                                            19/24 
  Verifica in corso : 14:libpcap-1.5.0-1.20131108git459712e.fc20.x86_64                                                        20/24 
  Verifica in corso : ibus-libs-1.5.4-2.fc20.x86_64                                                                            21/24 
  Verifica in corso : ibus-setup-1.5.4-2.fc20.noarch                                                                           22/24 
  Verifica in corso : file-5.14-12.fc20.x86_64                                                                                 23/24 
  Verifica in corso : ibus-gtk3-1.5.4-2.fc20.x86_64                                                                            24/24 

Aggiornato:
  file.x86_64 0:5.14-14.fc20                   file-libs.x86_64 0:5.14-14.fc20           firefox.x86_64 0:26.0-5.fc20              
  gnome-abrt.x86_64 0:0.3.5-1.fc20             ibus.x86_64 0:1.5.5-1.fc20                ibus-gtk2.x86_64 0:1.5.5-1.fc20           
  ibus-gtk3.x86_64 0:1.5.5-1.fc20              ibus-libs.x86_64 0:1.5.5-1.fc20           ibus-setup.noarch 0:1.5.5-1.fc20          
  ibus-wayland.x86_64 0:1.5.5-1.fc20           libpcap.x86_64 14:1.5.3-1.fc20           

Fallito:
  firefox.x86_64 0:26.0-3.fc20            nfs-utils.x86_64 1:1.2.8-6.0.fc20            nfs-utils.x86_64 1:1.2.9-2.1.fc20           

Completo!

Comment 1 Davide Repetto 2014-01-18 18:44:34 UTC

*** This bug has been marked as a duplicate of bug 1054350 ***


Note You need to log in before you can comment on or make changes to this bug.