Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1055044 - Systemd must be made more verbose
Summary: Systemd must be made more verbose
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 20
Hardware: All
OS: All
unspecified
urgent
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-18 09:20 UTC by Artem S. Tashkinov
Modified: 2014-01-23 18:29 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-23 18:29:49 UTC


Attachments (Terms of Use)

Description Artem S. Tashkinov 2014-01-18 09:20:12 UTC
I'm sure this bug won't receive any attention and it's gonna be closed as unreproduciable and meaningless but still.

Is it possible to show the current state or _every_ undertaken action of systemd as a fixed string at the top of the screen?

I mean let all systemd messages on start up and shut down be shown as usual, e.g. as a scrolling list. But the current state of systemd should be shown at the top, e.g.

┌─────────────────────────────────────────────────────────┐
│Systemd: waiting for X to start|waiting for X to stop      -> fixed on top
│
│Action1 ...
│Action1 ...
│[OK] Action1 started
│Action2 ...
│Action2 ...
│[OK] Action1 stopped
| etc.
|
|
└─────────────────────────────────────────────────────────┘

Systemd: waiting for X to start|waiting for X to stop|un/mounting this or that|loading module A/B/C|Setting hostname|etc. etc. etc.

In short _every_ systemd action which can be described in some way should be shown.

Why am I asking that?

I've just installed Fedora 20 and on reboot systemd hung. Of course, I pressed Esc to exit plymouth to see what's going on with systemd but nothing - it showed pretty much nothing to identify what was going on.

I couldn't even Sysrq+S-U-B since Fedora developers decided that U and B must be enabled.

Comment 1 Lennart Poettering 2014-01-23 13:04:48 UTC
Note that systemd will show what it is waiting for after a bit of time passed if plymouth is not used, to help the admin figure our what is going wrong. It will even show a small animation next to it after that time passed ("eye of sauron").

This current logic is simple, but quite robust, I am surprised that you didn't see that output?

Writing something in more complex ways to the beginning of the screen is not really possible without full ncurses hook-up or losing the ability to work on a big part of the existing terminals without problems.

What kind of terminal and boot display are you using? plymouth? VT?

Comment 2 Zbigniew Jędrzejewski-Szmek 2014-01-23 13:18:57 UTC
(In reply to Lennart Poettering from comment #1)
> ("eye of sauron").
cylon?

Comment 3 Artem S. Tashkinov 2014-01-23 18:29:49 UTC
> This current logic is simple, but quite robust, I am surprised that you didn't see that output?

I waited for at least a minute before I hard reset the PC, so I'm not sure this so called "eye of sauron" indeed works as intended.

Anyways, next time I will wait for a sufficient amount of time before raising the alarm and this time I'm closing this bug report.

> What kind of terminal and boot display are you using? plymouth? VT?

I'm on default Fedora installation so I've no idea what that is. Plymouth is indeed installed.


Note You need to log in before you can comment on or make changes to this bug.