Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 10548 - rpm -Fvh against multiple ix86 architectures
Summary: rpm -Fvh against multiple ix86 architectures
Keywords:
Status: CLOSED DUPLICATE of bug 7771
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-03 17:06 UTC by Mihai Ibanescu
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-12-30 14:09:11 UTC


Attachments (Terms of Use)

Description Mihai Ibanescu 2000-04-03 17:06:44 UTC
RedHat ships several packages compiled for several processors. For
instance, there is a gzip-x.y.z-i386.rpm and a gzip-x.y.x-i586.rpm

Having installed gzip-a.b.c-i386.rpm (for instance), where a.b.c < x.y.z,
trying

rpm -Fvh gzip-x.y.z-i?86.rpm

fails, with a lot of conflicts between the files from the two packages.

This is easily to reproduce.
Maybe NOTABUG, but annoying anyway.

Comment 1 Jeff Johnson 2000-08-07 13:43:13 UTC
Very annoying.

This problem will be addressed after rpm-4.0 is released.

Comment 2 Gerald Teschl 2000-12-30 10:45:28 UTC
rpm 4.0 has been released;-)

Comment 3 Jeff Johnson 2000-12-30 14:09:08 UTC
And the issue is still being addressed.

Comment 4 Jeff Johnson 2001-01-09 16:05:20 UTC
Collecting duplicates at bugzilla #7771

*** This bug has been marked as a duplicate of 7771 ***


Note You need to log in before you can comment on or make changes to this bug.