Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1054769 - [rhevm-reports] files are edited in /usr
Summary: [rhevm-reports] files are edited in /usr
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.4.0
Assignee: Alon Bar-Lev
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-01-17 12:52 UTC by Jiri Belka
Modified: 2014-09-18 12:24 UTC (History)
13 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
With this update, the Reports feature is no longer deployed to the /usr/share directory, and is instead deployed to the /var/lib directory to prevent writing to the /usr/share directory.
Clone Of:
Environment:
Last Closed: 2014-06-09 15:26:54 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0602 normal SHIPPED_LIVE rhevm-reports 3.4 bug fix and enhancement update 2014-06-09 19:26:10 UTC
oVirt gerrit 23315 None None None Never
oVirt gerrit 23316 None None None Never
oVirt gerrit 23317 None None None Never

Description Jiri Belka 2014-01-17 12:52:36 UTC
Description of problem:
Again another odd way where RHEVM keeps files to configure some feature.

This time - mail server - configuration of scheduler.

# rpm -qf /usr/share/ovirt-engine/rhevm-reports.war/WEB-INF/js.quartz.properties
file /usr/share/ovirt-engine/rhevm-reports.war/WEB-INF/js.quartz.properties is not owned by any package

[root@test ~]# cat -n /usr/share/ovirt-engine/rhevm-reports.war/WEB-INF/js.quartz.properties
     1  # This file will consolidate all the configurable quartz properties
     2  #
     3  # Other properties which didn't need configuration are kept in js.quartz.base.properties
     4
     5  quartz.delegateClass=org.quartz.impl.jdbcjobstore.PostgreSQLDelegate
     6
     7  quartz.tablePrefix=QRTZ_
     8  quartz.extraSettings=
     9
    10  report.scheduler.web.deployment.uri=http://localhost:8080/rhevm-reports
    11
    12  report.scheduler.mail.sender.host=mail.localhost.com
    13  report.scheduler.mail.sender.username=admin
    14  report.scheduler.mail.sender.password=password
    15  report.scheduler.mail.sender.from=admin@localhost.com
    16  report.scheduler.mail.sender.protocol=smtp
    17  report.scheduler.mail.sender.port=25

/usr! Should be in /etc! Would it survive upgrade?

I would propose one general configuration file for all similar configuration options, somewhere in /etc/sysconfig. Sorry but mail server configuration could be shared with notifier...

Version-Release number of selected component (if applicable):
is32.2 rhevm-reports-3.3.0-28.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
configuration is in /usr

Expected results:
/etc, all toys in /etc

Additional info:

Comment 1 Yaniv Lavi 2014-01-19 09:51:54 UTC
We use JRS which packages all it's config in the WAR folder. 
We can not control this and we preserve the user settings in upgrades.
In 3.4 we moved the war from /usr, so no changes will be done there after that.



Yaniv

Comment 2 Gil Klein 2014-01-19 19:33:38 UTC
Reopening for 3.4 so QE will be able to verify it for the next release.

Comment 3 Yaniv Lavi 2014-01-21 09:02:42 UTC

*** This bug has been marked as a duplicate of bug 1041124 ***

Comment 6 Jiri Belka 2014-01-21 12:22:51 UTC
This cannot be duplicate of BZ1041124 because this BZ is about rhevm-reports and the other bug is about rhevm-dwh.

Comment 7 Jiri Belka 2014-02-13 13:58:54 UTC
jasperreports-server-5.5.0-7.el6 needed for verification (alonbl@ informed).

Comment 8 Alon Bar-Lev 2014-02-13 14:02:36 UTC
(In reply to Jiri Belka from comment #7)
> jasperreports-server-5.5.0-7.el6 needed for verification (alonbl@ informed).

also newer version of ovirt-engine-reports, beta2 did not include something that is usable.

Comment 9 Jiri Belka 2014-02-17 09:03:18 UTC
Please put back to ON_QA when there's new version which fixes the issue. comment#8 clearly states beta2 did not contain the fix. Thank you.

Comment 10 Yaniv Lavi 2014-02-20 12:55:57 UTC
Beta 3 released.


Yaniv

Comment 11 Jiri Belka 2014-03-06 13:48:16 UTC
ok, av2, it's out of /usr now.

# find /var -type f -name 'js.quartz.properties' | xargs rpm -qf
file /var/lib/ovirt-engine-reports/build-conf/webapp/WEB-INF/js.quartz.properties is not owned by any package
file /var/lib/ovirt-engine-reports/build-conf/js.quartz.properties is not owned by any package
file /var/lib/ovirt-engine-reports/ovirt-engine-reports.war/WEB-INF/classes/js.quartz.properties is not owned by any package
file /var/lib/ovirt-engine-reports/ovirt-engine-reports.war/WEB-INF/js.quartz.properties is not owned by any package

Comment 12 errata-xmlrpc 2014-06-09 15:26:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0602.html


Note You need to log in before you can comment on or make changes to this bug.