Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1054743 - Run Once - no way how to start without a CD if one is defined in Edit VM
Summary: Run Once - no way how to start without a CD if one is defined in Edit VM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Martin Betak
QA Contact: Pavel Novotny
URL:
Whiteboard: virt
: 1026306 (view as bug list)
Depends On:
Blocks: 1026306 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-01-17 11:24 UTC by Michal Skrivanek
Modified: 2015-02-17 08:27 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Bug Fix
Doc Text:
Cause: CD-rom setting was always taken from VM configuration. Run once value of selected CD was ignored. Consequence: Impossible to "eject" CD for run once. Fix: Now run once setting always overrides persistent configuration.
Clone Of:
Environment:
Last Closed: 2015-02-17 08:27:21 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 25957 None None None Never

Description Michal Skrivanek 2014-01-17 11:24:01 UTC
in is30, VM without HD or NIC

Edit VM -> Boot Options -> Attach CD, attach something

go to Run Once -> Boot Options, Attach CD is unchecked, but if you run the VM it will be booted with the original CD

The Boot Sequence is all greyed out(like there's nothing to boot from), yet it boots from CD.

OTOH if you add NIC, put CDROM as the first device to boot from, allow PXE boot as the second device. 
Run Once
boots via PXE but if it fails it's still booting from CD
(boot sequence is "greyed out HD, greyed out CD, PXE")

Comment 1 Michal Skrivanek 2014-02-05 14:54:48 UTC
may be related to bug 1026306

Comment 2 Michal Skrivanek 2014-03-26 13:04:17 UTC
*** Bug 1026306 has been marked as a duplicate of this bug. ***

Comment 3 Pavel Novotny 2014-08-12 12:24:06 UTC
Verified upstream in ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch (rc1).

Verification steps:
1. VM -> edit -> Boot Options -> Attach CD: CentOS-6.5-x86_64-minimal.iso (for example).
2. VM -> Run Once -> Boot Options:

Results:
Attach CD is checked and set to CentOS-6.5-x86_64-minimal.iso.
Boot Sequence is enabled and can be changed.
The VM then boots according to the boot sequence set in run once dialog.

Comment 4 Omer Frenkel 2015-02-17 08:27:21 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.