Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1054667 - [rhevm-reports-setup] (remote install) avoid hard-code DB name by allowing the user to define it
Summary: [rhevm-reports-setup] (remote install) avoid hard-code DB name by allowing th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.5.0
Assignee: Yedidyah Bar David
QA Contact: movciari
URL:
Whiteboard: integration
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-01-17 08:52 UTC by Jiri Belka
Modified: 2015-02-11 18:16 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In Red Hat Enterprise Virtualization versions prior to 3.4, the database name was hardcoded and it was not possible to specify a different database name. With this update, the reports setup utility was replaced with a plug-in to use with the common engine-setup utility, and this plug-in queries all database credentials. This feature was considered as a tech preview feature in Red Hat Enterprise Virtualization 3.4 and is now a supported feature.
Clone Of:
Environment:
Last Closed: 2015-02-11 18:16:49 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0176 normal SHIPPED_LIVE rhevm-reports 3.5 bug fix and enhancement update 2015-02-11 23:11:58 UTC

Description Jiri Belka 2014-01-17 08:52:42 UTC
Description of problem:

Same as BZ1054259 but for rhevm-reports-setup...

[root@test ~]# rhevm-reports-setup 
Welcome to rhevm-reports setup utility
In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service (yes|no): 
Would you like to stop the ovirt-engine service (yes|no): yes
Stopping ovirt-engine...                              [ DONE ]
Remote database not found.
Remote installation selected. Make sure that DBA creates a user and the database in the following fashion:
        create role <role> with login encrypted password '<password>';
        create database rhevmreports template template0 encoding 'UTF8' lc_collate 'en_US.UTF-8' lc_ctype 'en_US.UTF-8' owner <role>;

Provide a remote DB user : remote_rhevmreports
Please choose a password for the db user: 
Re-type password: 
Editing XML files...                                  [ DONE ]
Setting DB connectivity...                            [ DONE ]
Please choose a password for the reports admin user(s) (rhevm-admin and superuser): 
Warning: Weak Password.
Retype password: 
Warning: Weak Password.
Deploying Server...

Version-Release number of selected component (if applicable):
is32.2 - rhevm-reports-3.3.0-28.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. clean remote install for engine
2. remote DB host: "create role <role> with login encrypted password <password>;" + "create database remote_rhevmreports template template0 encoding 'UTF8' lc_collate 'en_US.UTF-8' lc_ctype 'en_US.UTF-8' owner <role>;"
3. rhevm-reports-setup and try to user 'remote_rhevmrepors' DB

Actual results:
rhevm-reports-setup has hardcoded DB name

Expected results:
ask user for DB name (as he created the DB called 'remote_rhevmreports')

Additional info:

Comment 1 Yedidyah Bar David 2014-04-22 09:12:01 UTC
This bug affects only 3.3. In 3.4+ we do ask for everything. Not sure we should really solve it for 3.3 at this point in time.

Comment 2 Yaniv Lavi 2014-05-08 10:20:59 UTC
should be in the code of first release. Please test once it's out.



Yaniv

Comment 4 Julie 2015-01-30 05:44:45 UTC
Hi didi,
   I have updated the doc text. Please let me know if this is correct or not. 

Cheers,
Julie

Comment 5 Yedidyah Bar David 2015-02-01 07:28:24 UTC
Looks good to me.

Comment 7 errata-xmlrpc 2015-02-11 18:16:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0176.html


Note You need to log in before you can comment on or make changes to this bug.