Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1054663 - ISE when adding Red Hat errata to custom channel (ORA-00911: invalid character)
Summary: ISE when adding Red Hat errata to custom channel (ORA-00911: invalid character)
Keywords:
Status: CLOSED DUPLICATE of bug 1053436
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2014-01-17 08:40 UTC by Jan Hutař
Modified: 2014-01-17 09:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-17 09:19:08 UTC


Attachments (Terms of Use)
relevant part of catalina.out (deleted)
2014-01-17 08:41 UTC, Jan Hutař
no flags Details

Description Jan Hutař 2014-01-17 08:40:01 UTC
Description of problem:
On Satellite 5.6.0 with Oracle DB backend there is ISE when you attempt to add Red Hat errata to custom channel.


Version-Release number of selected component (if applicable):
spacewalk-schema-2.0.2-13.el6sat.noarch
spacewalk-java-2.0.2-50.el6sat.noarch


How reproducible:
always on one system

Steps to Reproduce:
I'm not perfectly clear if this is the case of one specific system or all Satellite deployments, but this is what I have done:
1. Channels -> Manage Software Channels -> <some_custom_channel>
   -> Errata -> Add -> Add Red Hat Errata


Actual results:
ISE

[...]
2014-01-17 03:34:09,325 [TP-Processor1] ERROR com.redhat.rhn.common.db.datasource.CachedStatement - Error while processing cached statement sql: SELECT DISTINCT E.id, E.advisory_name AS advisory,
                E.update_date AS UPDATE_DATE,
                E.synopsis as ADVISORY_SYNOPSIS,
                E.advisory_type as ADVISORY_TYPE
   FROM rhnErrata E inner join
        rhnChannelErrata CE on CE.errata_id = E.id inner join
        rhnSet S on S.element = CE.channel_id inner join
        rhnErrataPackage EP on EP.errata_id = E.id inner join
        rhnPackage P on p.id = EP.package_id inner join
        rhnPackage P2 on P.name_id = P2.name_id inner join
        rhnChannelPackage CP on P2.id = CP.package_id
  WHERE
    CP.channel_id = ?
    and S.user_id = ?
    and S.label = 'channels_for_errata'
    and E.id not in (select errata_id from rhnChannelErrata where channel_id = ?)
    and E.id not in (select original_id from rhnChannelErrata CE, rhnErrataCloned EC where CE.errata_id = EC.id and CE.channel_id = ?);
com.redhat.rhn.common.db.WrappedSQLException: ORA-00911: invalid character
[...]


Expected results:
Should display the form

Comment 1 Jan Hutař 2014-01-17 08:41:04 UTC
Created attachment 851471 [details]
relevant part of catalina.out

Comment 3 Jan Hutař 2014-01-17 08:46:56 UTC
This does not seem to be a problem on Satellite with PostgreSQL DB backend.

Comment 5 Michael Mráka 2014-01-17 09:19:08 UTC

*** This bug has been marked as a duplicate of bug 1053436 ***


Note You need to log in before you can comment on or make changes to this bug.