Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1054259 - [rhevm-dwh-setup] (remote install) avoid hard-code DB name by allowing the user to define it
Summary: [rhevm-dwh-setup] (remote install) avoid hard-code DB name by allowing the us...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.5.0
Assignee: Yedidyah Bar David
QA Contact: movciari
URL:
Whiteboard: integration
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-01-16 14:17 UTC by Jiri Belka
Modified: 2015-02-11 18:14 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when using a remote database and running the ovirt-engine-dwh-setup, the wizard did not ask for the remote database name, as it was hardcoded. In Red Hat Enterprise Virtualization 3.4, the DWH setup utility was replaced with a plug-in to use the common engine-setup utility and made it possible to input a database host as needed when setting up DWH with a remote database. This feature was a Tech Preview feature in Red Hat Enterprise Virtualization 3.4, and now a supported feature in 3.5.
Clone Of:
Environment:
Last Closed: 2015-02-11 18:14:26 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0177 normal SHIPPED_LIVE rhevm-dwh 3.5 bug fix and enhancement update 2015-02-11 23:11:50 UTC

Description Jiri Belka 2014-01-16 14:17:17 UTC
Description of problem:

# rhevm-dwh-setup 
Welcome to ovirt-engine-dwh setup utility

In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service (yes|no): yes
Stopping ovirt-engine...                              [ DONE ]
Remote installation is selected.

Remote installation selected. Make sure that DBA creates a user and the database in the following fashion:
        create role <role> with login encrypted password <password>;
        create database ovirt_engine_history template template0 encoding 'UTF8' lc_collate 'en_US.UTF-8' lc_ctype 'en_US.UTF-8' owner <role>;

Provide a remote DB user:  :  [engine_history]remote_engine_history
Please choose a password for the db user: 
Warning: Weak Password.
Re-type password: 
Could not connect to remote database - please try again.

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ - yes, my DB was not called 'ovirt_engine_history' but 'remote_engine_history' as it was hosted on other RHEVM setup (but not having dwh/reports configured).


I found in PG log that there was an attempt to connect to 'ovirt_engine_history'.

# egrep "^(FATAL|ERROR)" /var/lib/pgsql/data/pg_log/postgresql-Thu.log
ERROR:  syntax error at or near "ls" at character 1
FATAL:  password authentication failed for user "engine_history"
FATAL:  database "ovirt_engine_history" does not exist
FATAL:  password authentication failed for user "engine_history"
FATAL:  database "ovirt_engine_history" does not exist
FATAL:  Ident authentication failed for user "root"
FATAL:  Ident authentication failed for user "postgres"
ERROR:  relation "history_configuration" does not exist at character 15
ERROR:  relation "history_configuration" does not exist at character 15
ERROR:  relation "history_configuration" does not exist at character 15


`rhevm-dwh-setup' should allow to define DB name for (remote) installations.

Version-Release number of selected component (if applicable):
is32.2 - rhevm-dwh-3.3.0-28.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. clean remote install for engine
2. remote DB host: "create role <role> with login encrypted password <password>;" + "create database foobar template template0 encoding 'UTF8' lc_collate 'en_US.UTF-8' lc_ctype 'en_US.UTF-8' owner <role>;"
3. rhevm-dwh-setup

Actual results:
rhevm-dwh-setup has hardcoded DB name

Expected results:
ask user for DB name (as he created the DB called 'foobar')

Additional info:

Comment 1 Yedidyah Bar David 2014-04-22 09:12:16 UTC
This bug affects only 3.3. In 3.4+ we do ask for everything. Not sure we should really solve it for 3.3 at this point in time.

Comment 2 Yaniv Lavi 2014-05-08 10:14:43 UTC
Should be in for 3.5. Please test this.


Yaniv

Comment 5 errata-xmlrpc 2015-02-11 18:14:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0177.html


Note You need to log in before you can comment on or make changes to this bug.